]> git.pld-linux.org Git - packages/python-gnome-desktop.git/blob - python-gnome-desktop.spec
1904f95f0f0dc58dbb5d1091c488d865b093cc50
[packages/python-gnome-desktop.git] / python-gnome-desktop.spec
1 #
2 # NOTE: evince, brasero and mediaprofiles are disabled because these things have
3 # been ported to GTK+3. It's not practical to mix GTK+2 and GTK+3 bindings
4 # in gnome-python2-desktop, so for now we'll just have to disable the GTK+3
5 # stuff.
6 #
7 # Conditional builds:
8 %bcond_without  totem           # disable totem support
9
10 %define         module                  gnome-python-desktop
11 %define         pygtk_req               2:2.12.0
12 %define         gnome_python_req        2.26.0
13 Summary:        GNOME bindings for Python
14 Summary(pl.UTF-8):      Wiązania Pythona do bibliotek GNOME
15 Name:           python-gnome-desktop
16 Version:        2.32.0
17 Release:        11
18 License:        GPL v2/LGPL v2.1 (see COPYING)
19 Group:          Libraries/Python
20 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gnome-python-desktop/2.32/%{module}-%{version}.tar.bz2
21 # Source0-md5:  0e73fa80ace5c861777e0b523c6ead9d
22 BuildRequires:  GConf2-devel >= 2.22.0
23 BuildRequires:  autoconf >= 2.53
24 BuildRequires:  automake
25 BuildRequires:  evolution-data-server-devel
26 BuildRequires:  gnome-desktop2-devel >= 2.10.0
27 BuildRequires:  gnome-vfs2-devel >= 2.22.0
28 BuildRequires:  gtk+2-devel >= 2:2.12.0
29 BuildRequires:  gtksourceview-devel >= 1.8.4
30 BuildRequires:  libgnome-keyring-devel >= 2.22.0
31 BuildRequires:  libgnomeprintui-devel >= 2.18.1
32 BuildRequires:  libgnomeui-devel
33 BuildRequires:  libgtop-devel >= 2.22.0
34 BuildRequires:  librsvg-devel >= 1:2.22.0
35 BuildRequires:  libtool
36 BuildRequires:  libwnck2-devel >= 2.22.0
37 BuildRequires:  pkgconfig
38 BuildRequires:  python-devel >= 1:2.3.2
39 BuildRequires:  python-gnome-devel >= %{gnome_python_req}
40 BuildRequires:  python-pycairo-devel
41 BuildRequires:  python-pygtk-devel >= %{pygtk_req}
42 BuildRequires:  rpm-pythonprov
43 BuildRequires:  rpmbuild(macros) >= 1.336
44 %{?with_totem:BuildRequires:    totem-pl-parser-devel >= 1.6.0}
45 Requires:       python-modules
46 Obsoletes:      python-evolution
47 Obsoletes:      python-gnome-applet
48 Obsoletes:      python-gnome-desktop-applet
49 Obsoletes:      python-gnome-desktop-brasero
50 Obsoletes:      python-gnome-desktop-evince
51 Obsoletes:      python-gnome-desktop-evolution
52 Obsoletes:      python-gnome-desktop-mediaprofiles
53 Obsoletes:      python-gnome-desktop-nautilus-cd-burner
54 Obsoletes:      python-gnome-extras-applet
55 Obsoletes:      python-gnome-extras-mediaprofiles
56 Obsoletes:      python-gnome-extras-nautilus-cd-burner
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %define pydefsdir %(pkg-config --variable=defsdir pygtk-2.0)
60
61 %description
62 GNOME bindings for Python.
63
64 %description -l pl.UTF-8
65 Wiązania Pythona do bibliotek GNOME.
66
67 %package devel
68 Summary:        Development files for GNOME bindings for Python
69 Summary(pl.UTF-8):      Pliki programistyczne wiązań Pythona do GNOME
70 Group:          Libraries/Python
71 Requires:       %{name}-libwnck = %{version}-%{release}
72 Requires:       %{name}-print = %{version}-%{release}
73 Requires:       python-gnome-devel >= %{gnome_python_req}
74 Requires:       python-pygtk-devel >= %{pygtk_req}
75 Obsoletes:      python-gnome-extras-devel < 2.13.3
76
77 %description devel
78 Development files for GNOME bindings for Python.
79
80 %description devel -l pl.UTF-8
81 Pliki programistyczne wiązań Pythona do GNOME.
82
83 %package apidocs
84 Summary:        GNOME bindings for Python API documentation
85 Summary(pl.UTF-8):      Dokumentacja API wiązań Pythona do GNOME
86 Group:          Documentation
87 Requires:       gtk-doc-common
88 %if "%{_rpmversion}" >= "5"
89 BuildArch:      noarch
90 %endif
91
92 %description apidocs
93 GNOME bindings for Python API documentation.
94
95 %description apidocs -l pl.UTF-8
96 Dokumentacja API wiązań Pythona do GNOME.
97
98 %package examples
99 Summary:        Example programs for python-gnome-desktop
100 Summary(pl.UTF-8):      Przykładowe programy do python-gnome-desktop
101 Group:          Libraries/Python
102 Requires:       %{name}-devel = %{version}-%{release}
103
104 %description examples
105 This package contains example programs for python-gnome-desktop.
106
107 %description examples -l pl.UTF-8
108 Ten pakiet zawiera przykładowe programy dla python-gnome-desktop.
109
110 %package gtksourceview
111 Summary:        Gtksourceview bindings for Python
112 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki gtksourceview
113 Group:          Libraries/Python
114 Requires:       %{name}-print = %{version}-%{release}
115 Obsoletes:      python-gnome-extras-gtksourceview
116
117 %description gtksourceview
118 Gtksourceview bindings for Python.
119
120 %description gtksourceview -l pl.UTF-8
121 Wiązania Pythona do biblioteki gtksourceview.
122
123 %package keyring
124 Summary:        GNOME keyring bindings for Python
125 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki GNOME keyring
126 Group:          Libraries/Python
127 Requires:       python-pygobject >= 2.14.0
128
129 %description keyring
130 GNOME keyring bindings for Python.
131
132 %description keyring -l pl.UTF-8
133 Wiązania Pythona do biblioteki GNOME keyring.
134
135 %package libgtop
136 Summary:        Libgtop bindings for Python
137 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki libgtop
138 Group:          Libraries/Python
139 Requires:       python-pygobject >= 2.14.0
140 Obsoletes:      python-gnome-extras-libgtop
141
142 %description libgtop
143 Libgtop bindings for Python.
144
145 %description libgtop -l pl.UTF-8
146 Wiązania Pythona do biblioteki libgtop.
147
148 %package librsvg
149 Summary:        Librsvg bindings for Python
150 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki librsvg
151 Group:          Libraries/Python
152 Requires:       librsvg >= 1:2.22.0
153
154 %description librsvg
155 Librsvg bindings for Python.
156
157 %description librsvg -l pl.UTF-8
158 Wiązania Pythona do biblioteki librsvg.
159
160 %package libwnck
161 Summary:        Libwnck bindings for Python
162 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki libwnck
163 Group:          Libraries/Python
164 Requires:       python-pygtk-gtk >= %{pygtk_req}
165 Obsoletes:      python-gnome-extras-libwnck
166
167 %description libwnck
168 Libwnck bindings for Python.
169
170 %description libwnck -l pl.UTF-8
171 Wiązania Pythona do biblioteki libwnck.
172
173 %package print
174 Summary:        GNOME Print bindings for Python
175 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki GNOME obsługi drukowania
176 Group:          Libraries/Python
177 Requires:       %{name} = %{version}-%{release}
178 Requires:       python-gnome-canvas >= %{gnome_python_req}
179 Provides:       python-gnome-print
180 Provides:       python-gnome-print-ui
181 Obsoletes:      python-gnome-extras-print
182 Obsoletes:      python-gnome-print
183 Obsoletes:      python-gnome-print-ui
184
185 %description print
186 GNOME Print bindings for Python.
187
188 %description print -l pl.UTF-8
189 Wiązania Pythona do biblioteki GNOME obsługi drukowania.
190
191 %package totem
192 Summary:        Totem bindings for Python
193 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki totem
194 Group:          Libraries/Python
195 Requires:       python-gnome-vfs >= %{gnome_python_req}
196 Requires:       python-pygtk-gtk >= %{pygtk_req}
197 Obsoletes:      python-gnome-extras-totem
198
199 %description totem
200 Totem bindings for Python.
201
202 %description totem -l pl.UTF-8
203 Wiązania Pythona do biblioteki totem.
204
205 %prep
206 %setup -q -n %{module}-%{version}
207
208 %build
209 %{__libtoolize}
210 %{__aclocal}
211 %{__autoconf}
212 %{__autoheader}
213 %{__automake}
214 %configure \
215         --disable-applet \
216         --disable-braseromedia \
217         --disable-braseroburn \
218         --disable-bugbuddy \
219         --disable-evolution \
220         --disable-evolution_ecal \
221         --disable-evince \
222         --disable-mediaprofiles \
223         --disable-nautilusburn
224 %{__make}
225
226 %install
227 rm -rf $RPM_BUILD_ROOT
228 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
229
230 %{__make} install \
231         DESTDIR=$RPM_BUILD_ROOT
232
233 %py_comp $RPM_BUILD_ROOT%{py_sitedir}/gtk-2.0
234 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}/gtk-2.0
235
236 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
237
238 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/gtk-2.0/{*.la,*/*.{py,la}}
239
240 # wscript doesn't allow to pass proper gtk-doc dir
241 if [ ! -d $RPM_BUILD_ROOT%{_gtkdocdir} ]; then
242         install -d $RPM_BUILD_ROOT%{_gtkdocdir}
243         mv $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/* $RPM_BUILD_ROOT%{_gtkdocdir}
244 fi
245
246 %clean
247 rm -rf $RPM_BUILD_ROOT
248
249 %files
250 %defattr(644,root,root,755)
251 %doc AUTHORS COPYING ChangeLog NEWS
252 %dir %{py_sitedir}/gtk-2.0/gnomedesktop
253 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnomedesktop/_gnomedesktop.so
254 %{py_sitedir}/gtk-2.0/gnomedesktop/__init__.py[co]
255
256 %files devel
257 %defattr(644,root,root,755)
258 %{pydefsdir}/*.defs
259 %{_pkgconfigdir}/gnome-python-desktop-2.0.pc
260
261 %files apidocs
262 %defattr(644,root,root,755)
263 %{_gtkdocdir}/pygnomeprint
264 %{_gtkdocdir}/pygnomeprintui
265 %{_gtkdocdir}/pygtksourceview
266
267 %files examples
268 %defattr(644,root,root,755)
269 %{_examplesdir}/%{name}-%{version}
270
271 %files gtksourceview
272 %defattr(644,root,root,755)
273 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gtksourceview.so
274
275 %files keyring
276 %defattr(644,root,root,755)
277 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnomekeyring.so
278
279 %files libgtop
280 %defattr(644,root,root,755)
281 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gtop.so
282
283 %files librsvg
284 %defattr(644,root,root,755)
285 %attr(755,root,root) %{py_sitedir}/gtk-2.0/rsvg.so
286
287 %files libwnck
288 %defattr(644,root,root,755)
289 %attr(755,root,root) %{py_sitedir}/gtk-2.0/wnck.so
290
291 %files print
292 %defattr(644,root,root,755)
293 %dir %{py_sitedir}/gtk-2.0/gnomeprint
294 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnomeprint/_print.so
295 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnomeprint/ui.so
296 %{py_sitedir}/gtk-2.0/gnomeprint/__init__.py[co]
297
298 %if %{with totem}
299 %files totem
300 %defattr(644,root,root,755)
301 %dir %{py_sitedir}/gtk-2.0/totem
302 %attr(755,root,root) %{py_sitedir}/gtk-2.0/totem/plparser.so
303 %{py_sitedir}/gtk-2.0/totem/__init__.py[co]
304 %endif
This page took 0.063059 seconds and 2 git commands to generate.