]> git.pld-linux.org Git - packages/python-git.git/blob - python-git.spec
- up to 2.1.15, last version supporting python2
[packages/python-git.git] / python-git.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # unit tests (require git checkout, not archive?)
4 %bcond_without  doc     # Sphinx documentation
5
6 Summary:        Python Git Library
7 Summary(pl.UTF-8):      Biblioteka Git dla Pythona
8 Name:           python-git
9 Version:        2.1.15
10 Release:        1
11 License:        BSD
12 Group:          Development/Languages/Python
13 #Source0Download: https://github.com/gitpython-developers/GitPython/releases
14 Source0:        https://github.com/gitpython-developers/GitPython/archive/%{version}/GitPython-%{version}.tar.gz
15 # Source0-md5:  e6dfd0204f5b626f69ae904a2e392c91
16 URL:            https://pypi.org/project/GitPython/
17 BuildRequires:  python-modules >= 1:2.7
18 BuildRequires:  python-setuptools
19 %if %{with tests}
20 BuildRequires:  python-ddt >= 1.1.1
21 BuildRequires:  python-gitdb >= 2.0.0
22 %endif
23 BuildRequires:  rpm-pythonprov
24 BuildRequires:  rpmbuild(macros) >= 1.714
25 %{?with_doc:BuildRequires:      sphinx-pdg}
26 Requires:       python-modules >= 1:2.7
27 Obsoletes:      GitPython
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 GitPython is a Python library used to interact with git repositories,
33 high-level like git-porcelain, or low-level like git-plumbing.
34
35 It provides abstractions of git objects for easy access of repository
36 data, and additionally allows you to access the git repository more
37 directly using either a pure Python implementation, or the faster, but
38 more resource intensive git command implementation.
39
40 %description -l pl.UTF-8
41 GitPython to biblioteka Pythona służąca do pracy z repozytoriami gita,
42 wysokopoziomowo, jak git-porcelain lub niskopoziomowo, jak
43 git-plumbing.
44
45 Biblioteka udostępnia abstrakcje obiektów gita, zapewniając łatwy
46 dostęp do danych repozytorium, a ponadto pozwala na dostęp do
47 repozytorium bardziej bezpośrednio albo przy użyciu czysto pythonowej
48 implementacji, albo szybciej, ale z większym zużyciem zasobów, przy
49 użyciu implementacji poleceń gita.
50
51 %package apidocs
52 Summary:        API documentation for GitPython library
53 Summary(pl.UTF-8):      Dokumentacja API biblioteki GitPython
54 Group:          Documentation
55
56 %description apidocs
57 API documentation for GitPython library.
58
59 %description apidocs -l pl.UTF-8
60 Dokumentacja API biblioteki GitPython.
61
62 %prep
63 %setup -q -n GitPython-%{version}
64
65 %build
66 %py_build %{?with_tests:test}
67
68 %if %{with doc}
69 %{__make} -C doc html
70 %endif
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %py_install
76
77 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/git/test
78
79 %py_postclean
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %files
85 %defattr(644,root,root,755)
86 %doc AUTHORS CHANGES LICENSE README.md
87 %dir %{py_sitescriptdir}/git
88 %{py_sitescriptdir}/git/*.py[co]
89 %{py_sitescriptdir}/git/index
90 %{py_sitescriptdir}/git/objects
91 %{py_sitescriptdir}/git/refs
92 %{py_sitescriptdir}/git/repo
93 %{py_sitescriptdir}/GitPython-%{version}-py*.egg-info
94
95 %if %{with doc}
96 %files apidocs
97 %defattr(644,root,root,755)
98 %doc doc/build/html/{_static,*.html,*.js}
99 %endif
This page took 0.0731889999999999 seconds and 3 git commands to generate.