]> git.pld-linux.org Git - packages/python-gammu.git/blob - python-gammu.spec
automatic change: use py_build/py_install macros
[packages/python-gammu.git] / python-gammu.spec
1 %define         module  python-gammu
2 Summary:        Python bindings for Gammu library.
3 Name:           %{module}
4 Version:        2.3
5 Release:        2
6 License:        GPL v2
7 Group:          Development/Languages/Python
8 Source0:        http://dl.cihar.com/python-gammu/%{module}-%{version}.tar.bz2
9 # Source0-md5:  e92b13cb6fa9681c48981340ffadd251
10 URL:            http://http://wammu.eu/python-gammu/
11 BuildRequires:  gammu-devel >= 1.34.0
12 BuildRequires:  python-devel
13 BuildRequires:  rpm-pythonprov
14 BuildRequires:  rpmbuild(macros) >= 1.219
15 Requires:       glibc >= 2.4
16 Requires:       python-modules
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Python bindings for Gammu library.
21
22 %prep
23 %setup -q -n %{module}-%{version}
24
25 %build
26 %py_build
27
28 %install
29 rm -rf $RPM_BUILD_ROOT
30 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
31 %py_install
32
33 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
34 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
35 %py_postclean
36
37 install examples/data/*.* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/data
38 install examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
39 #install examples/data/*.* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/data
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %files
45 %defattr(644,root,root,755)
46 %dir %{py_sitedir}/gammu
47 %attr(755,root,root) %{py_sitedir}/gammu/*.so
48 %{py_sitedir}/gammu/*.py[co]
49 %{py_sitedir}/python_gammu-%{version}-py*.egg-info
50 %{_examplesdir}/%{name}-%{version}
This page took 0.241753 seconds and 3 git commands to generate.