]> git.pld-linux.org Git - packages/python-gammu.git/blob - python-gammu.spec
89ed9b03bb5d187249e5b097dc5617fad116f638
[packages/python-gammu.git] / python-gammu.spec
1 %define         module  python-gammu
2 Summary:        Python bindings for Gammu library.
3 Name:           %{module}
4 Version:        2.3
5 Release:        2
6 License:        GPL v2
7 Group:          Development/Languages/Python
8 Source0:        http://dl.cihar.com/python-gammu/%{module}-%{version}.tar.bz2
9 # Source0-md5:  e92b13cb6fa9681c48981340ffadd251
10 URL:            http://http://wammu.eu/python-gammu/
11 BuildRequires:  gammu-devel >= 1.34.0
12 BuildRequires:  python-devel
13 BuildRequires:  rpm-pythonprov
14 BuildRequires:  rpmbuild(macros) >= 1.219
15 Requires:       glibc >= 2.4
16 Requires:       python-modules
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Python bindings for Gammu library.
21
22 %prep
23 %setup -q -n %{module}-%{version}
24
25 %build
26 export CFLAGS="%{rpmcflags}"
27 %{__python} setup.py build
28
29 %install
30 rm -rf $RPM_BUILD_ROOT
31 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
32 %{__python} setup.py install \
33         --optimize=2 \
34         --root=$RPM_BUILD_ROOT
35
36 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
37 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
38 %py_postclean
39
40 install examples/data/*.* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/data
41 install examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
42 #install examples/data/*.* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/data
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 %defattr(644,root,root,755)
49 %dir %{py_sitedir}/gammu
50 %attr(755,root,root) %{py_sitedir}/gammu/*.so
51 %{py_sitedir}/gammu/*.py[co]
52 %{py_sitedir}/python_gammu-%{version}-py*.egg-info
53 %{_examplesdir}/%{name}-%{version}
This page took 0.047957 seconds and 2 git commands to generate.