]> git.pld-linux.org Git - packages/python-futures.git/blob - python-futures.spec
- release 2 (by relup.sh)
[packages/python-futures.git] / python-futures.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Sphinx documentation
4 %bcond_without  tests   # unit tests
5
6 Summary:        Backport of the concurrent.futures package from Python 3.2
7 Summary(pl.UTF-8):      Backport pakietu concurrent.futures z Pythona 3.2
8 Name:           python-futures
9 Version:        3.3.0
10 Release:        2
11 License:        PSF v2
12 Group:          Libraries/Python
13 #Source0Download: https://pypi.org/simple/futures/
14 Source0:        https://files.pythonhosted.org/packages/source/f/futures/futures-%{version}.tar.gz
15 # Source0-md5:  b43a39ae1475e3fd6940f2b4f7214675
16 URL:            https://github.com/agronholm/pythonfutures
17 BuildRequires:  python-modules >= 1:2.6
18 BuildRequires:  python-setuptools
19 BuildRequires:  rpm-pythonprov
20 BuildRequires:  rpmbuild(macros) >= 1.714
21 %if %{with doc}
22 BuildRequires:  sphinx-pdg-2
23 %endif
24 Requires:       python-modules >= 1:2.6
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 The concurrent.futures module provides a high-level interface for
30 asynchronously executing callables.
31
32 %description -l pl.UTF-8
33 Moduł concurrent.futures udostępnia wysokopoziomowy interfejs do
34 asynchronicznego wykonywania procedur.
35
36 %package apidocs
37 Summary:        API documentation for Python concurrent.futures module
38 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona concurrent.futures
39 Group:          Documentation
40
41 %description apidocs
42 API documentation for Python concurrent.futures module.
43
44 %description apidocs -l pl.UTF-8
45 Dokumentacja API modułu Pythona concurrent.futures.
46
47 %prep
48 %setup -q -n futures-%{version}
49
50 %build
51 %py_build
52
53 %if %{with tests}
54 %{__python} test_futures.py
55 %endif
56
57 %if %{with doc}
58 %{__make} -C docs html \
59         SPHINXBUILD=sphinx-build-2
60 %endif
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 %py_install
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc LICENSE README.rst
73 %{py_sitescriptdir}/concurrent
74 %{py_sitescriptdir}/futures-%{version}-py*.egg-info
75
76 %if %{with doc}
77 %files apidocs
78 %defattr(644,root,root,755)
79 %doc docs/_build/html/{_static,*.html,*.js}
80 %endif
This page took 0.069775 seconds and 3 git commands to generate.