]> git.pld-linux.org Git - packages/python-functools32.git/blob - python-functools32.spec
- release 2 (by relup.sh)
[packages/python-functools32.git] / python-functools32.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # tests
4
5 Summary:        Backport of the functools module from Python 3.2.3 to Python 2.7
6 Summary(pl.UTF-8):      Backport modułu functools z Pythona 3.2.3 do 2.7
7 Name:           python-functools32
8 %define src_ver 3.2.3-2
9 Version:        %(echo %{src_ver} | tr - .)
10 %define egg_ver %(echo %{src_ver} | tr - _)
11 Release:        2
12 License:        PSF
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.python.org/simple/functools32/
15 Source0:        https://pypi.python.org/packages/c5/60/6ac26ad05857c601308d8fb9e87fa36d0ebf889423f47c3502ef034365db/functools32-%{src_ver}.tar.gz
16 # Source0-md5:  09f24ffd9af9f6cd0f63cb9f4e23d4b2
17 URL:            https://github.com/MiCHiLU/python-functools32
18 BuildRequires:  python-modules >= 1:2.7
19 BuildRequires:  rpm-pythonprov
20 BuildRequires:  rpmbuild(macros) >= 1.714
21 Requires:       python-modules >= 1:2.7
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 This is a backport of the functools standard library module from
27 Python 3.2.3 for use on Python 2.7 and PyPy. It includes new features
28 lru_cache (Least-recently-used cache decorator).
29
30 %description -l pl.UTF-8
31 Ten pakiet zawiera backport modułu functools z biblioteki standardowej
32 Pythona 3.2.3, przeznaczony dla Pythona 2.7 oraz PyPy. Obejmuje nową
33 funkcję lru_cache (dekorator pamięci podręcznej ostatnio użytych
34 elementów).
35
36 %prep
37 %setup -q -n functools32-%{src_ver}
38
39 %build
40 %py_build
41
42 %if %{with tests}
43 %{__python} test_functools32.py
44 %endif
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %py_install
50
51 %py_postclean
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc ChangeLog LICENSE
59 %{py_sitescriptdir}/functools32
60 %{py_sitescriptdir}/functools32-%{egg_ver}-py*.egg-info
This page took 0.283288 seconds and 3 git commands to generate.