]> git.pld-linux.org Git - packages/python-fpconst.git/blob - python-fpconst.spec
80cbbaabca40af7eafd35ca144a35f0ca9537416
[packages/python-fpconst.git] / python-fpconst.spec
1
2 %define         module  fpconst
3
4 Summary:        IEEE 754 floating point special handling
5 Summary(pl.UTF-8):      Specjalna obsługa liczb zmiennoprzecinkowych IEEE 754
6 Name:           python-%{module}
7 Version:        0.7.2
8 Release:        5
9 License:        Apache v2.0
10 Group:          Libraries/Python
11 Source0:        http://cheeseshop.python.org/packages/source/f/fpconst/fpconst-%{version}.tar.gz
12 # Source0-md5:  10ba9e04129af23108d24c22c3a698b1
13 URL:            http://research.warnes.net/projects/RStatServer/fpconst/index_html
14 BuildRequires:  rpmbuild(macros) >= 1.710
15 BuildRequires:  python >= 1:2.5
16 BuildRequires:  python-modules
17 BuildRequires:  rpm-pythonprov
18 %pyrequires_eq  python-modules
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This python module implements constants and functions for working with
24 IEEE 754 double-precision special values. It provides constants for
25 Not-a-Number (NaN), Positive Infinity (Inf), and Negative Infinity
26 (-Inf), as well as functions to test for these values.
27
28 %description -l pl.UTF-8
29 Ten moduł Pythona jest implementacją stałych i funkcji do pracy z
30 wartościami specjalnymi liczb podwójnej precyzji zgodnymi z IEEE 754.
31 Udostępnia stałe dla nie-liczb (NaN, czyli Not-a-Number), dodatniej
32 nieskończoności (Inf) i ujemnej nieskończoności (-Inf), a także
33 funkcje do porównywania z tymi wartościami.
34
35 %prep
36 %setup -q -n %{module}-%{version}
37
38 %build
39 %py_build
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 install -d $RPM_BUILD_ROOT%{py_sitescriptdir}
44
45 %py_install
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %doc README
53 %{py_sitescriptdir}/*.py[co]
54 %{py_sitescriptdir}/*.egg-info
This page took 0.049845 seconds and 2 git commands to generate.