]> git.pld-linux.org Git - packages/python-fontPens.git/blob - python-fontPens.spec
rebuild with tests and docs
[packages/python-fontPens.git] / python-fontPens.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests (disable to bootstrap fontParts and booleanOperations)
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 Summary:        Classes implementing the pen protocol for manipulating glyphs
8 Summary(pl.UTF-8):      Klasy implementujące protokół pióra do operacji na glifach
9 Name:           python-fontPens
10 Version:        0.2.4
11 Release:        4
12 License:        BSD
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.org/simple/fontpens/
15 Source0:        https://files.pythonhosted.org/packages/source/f/fontpens/fontPens-%{version}.zip
16 # Source0-md5:  ba666ed73e00da7ba2c84600b4bdeca0
17 URL:            https://pypi.org/project/fontpens/
18 %if %{with python2}
19 BuildRequires:  python-modules >= 1:2.7
20 BuildRequires:  python-setuptools
21 %if %{with tests}
22 BuildRequires:  python-fontParts >= 0.8.1
23 BuildRequires:  python-fonttools >= 3.32.0
24 BuildRequires:  python-pytest
25 %endif
26 %endif
27 %if %{with python3}
28 BuildRequires:  python3-modules >= 1:3.4
29 BuildRequires:  python3-setuptools
30 %if %{with tests}
31 BuildRequires:  python3-fontParts >= 0.8.1
32 BuildRequires:  python3-fonttools >= 3.32.0
33 BuildRequires:  python3-pytest
34 %endif
35 %endif
36 BuildRequires:  rpm-pythonprov
37 BuildRequires:  rpmbuild(macros) >= 1.714
38 BuildRequires:  unzip
39 Requires:       python-modules >= 1:2.7
40 BuildArch:      noarch
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 A collection of classes implementing the pen protocol for manipulating
45 glyphs.
46
47 %description -l pl.UTF-8
48 Zbiór klas implementujących protokół pióra do operacji na glifach.
49
50 %package -n python3-fontPens
51 Summary:        Classes implementing the pen protocol for manipulating glyphs
52 Summary(pl.UTF-8):      Klasy implementujące protokół pióra do operacji na glifach
53 Group:          Libraries/Python
54 Requires:       python3-modules >= 1:3.4
55
56 %description -n python3-fontPens
57 A collection of classes implementing the pen protocol for manipulating
58 glyphs.
59
60 %description -n python3-fontPens -l pl.UTF-8
61 Zbiór klas implementujących protokół pióra do operacji na glifach.
62
63 %prep
64 %setup -q -n fontPens-%{version}
65
66 %build
67 %if %{with python2}
68 %py_build
69
70 %if %{with tests}
71 PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
72 %{__python} -m pytest Lib/fontPens
73 %endif
74 %endif
75
76 %if %{with python3}
77 %py3_build
78
79 %if %{with tests}
80 PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
81 %{__python3} -m pytest Lib/fontPens
82 %endif
83 %endif
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87
88 %if %{with python2}
89 %py_install
90
91 %py_postclean
92 %endif
93
94 %if %{with python3}
95 %py3_install
96 %endif
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %if %{with python2}
102 %files
103 %defattr(644,root,root,755)
104 %doc LICENSE.txt README.rst
105 %{py_sitescriptdir}/fontPens
106 %{py_sitescriptdir}/fontPens-%{version}-py*.egg-info
107 %endif
108
109 %if %{with python3}
110 %files -n python3-fontPens
111 %defattr(644,root,root,755)
112 %doc LICENSE.txt README.rst
113 %{py3_sitescriptdir}/fontPens
114 %{py3_sitescriptdir}/fontPens-%{version}-py*.egg-info
115 %endif
This page took 0.095126 seconds and 3 git commands to generate.