]> git.pld-linux.org Git - packages/python-flask-script.git/blob - python-flask-script.spec
Release 9 (by relup.sh)
[packages/python-flask-script.git] / python-flask-script.spec
1 #
2 # Conditional build:
3 %bcond_without  doc             # don't build doc
4 %bcond_without  tests   # do not perform "make test"
5 %bcond_without  python2 # CPython 2.x module
6 %bcond_without  python3 # CPython 3.x module
7
8 %define         module  flask-script
9 Summary:        Scripting support for Flask
10 Summary(pl.UTF-8):      Wsparcie dla skryptów w Flask-
11 # Name must match the python module/package name (as in 'import' statement)
12 Name:           python-%{module}
13 Version:        2.0.5
14 Release:        9
15 License:        BSD
16 Group:          Libraries/Python
17 Source0:        https://pypi.python.org/packages/source/F/Flask-Script/Flask-Script-%{version}.tar.gz
18 # Source0-md5:  e5c73d3b7937f5b88942f342f9617029
19 URL:            http://github.com/smurfix/flask-script
20 BuildRequires:  rpmbuild(macros) >= 1.710
21 BuildRequires:  rpm-pythonprov
22 %if %{with python2}
23 BuildRequires:  python-distribute
24 BuildRequires:  python-flask
25 BuildRequires:  python-itsdangerous
26 BuildRequires:  python-pytest
27 %endif
28 %if %{with python3}
29 BuildRequires:  python3-flask
30 BuildRequires:  python3-itsdangerous
31 BuildRequires:  python3-modules
32 BuildRequires:  python3-pytest
33 %endif
34 Requires:       python-modules
35 Requires:       python-flask
36 BuildArch:      noarch
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 The Flask-Script extension provides support for writing external
41 scripts in Flask. This includes running a development server, a
42 customised Python shell, scripts to set up your database, cronjobs,
43 and other command-line tasks that belong outside the web application
44 itself.
45
46 %description -l pl.UTF-8
47 Rozszerzenie Flask-Script pozwala na pisanie zewnętrznych skryptów w
48 Flasku. Co dalej pozawala na uruchamianie serwera rozwojowego,
49 własnych skryptów w Pythonie, skryptów inicjujących bazę dane,
50 skryptów cronta i różnych inych zadań z lini poleceń, które nie należą
51 do samej aplikacji.
52
53 %package -n python3-%{module}
54 Summary:        -
55 Summary(pl.UTF-8):      -
56 Group:          Libraries/Python
57 Requires:       python3-modules
58 Requires:       python3-flask
59
60 %description -n python3-%{module}
61 The Flask-Script extension provides support for writing external
62 scripts in Flask. This includes running a development server, a
63 customised Python shell, scripts to set up your database, cronjobs,
64 and other command-line tasks that belong outside the web application
65 itself.
66
67 %description -n python3-%{module} -l pl.UTF-8
68 Rozszerzenie Flask-Script pozwala na pisanie zewnętrznych skryptów w
69 Flasku. Co dalej pozawala na uruchamianie serwera rozwojowego,
70 własnych skryptów w Pythonie, skryptów inicjujących bazę dane,
71 skryptów cronta i różnych inych zadań z lini poleceń, które nie należą
72 do samej aplikacji.
73
74
75 %package apidocs
76 Summary:        %{module} API documentation
77 Summary(pl.UTF-8):      Dokumentacja API %{module}
78 Group:          Documentation
79
80 %description apidocs
81 API documentation for %{module}.
82
83 %description apidocs -l pl.UTF-8
84 Dokumentacja API %{module}.
85
86 %prep
87 %setup -q -n Flask-Script-%{version}
88
89 %build
90 %if %{with python2}
91 %py_build %{?with_tests:test}
92 %endif
93
94 %if %{with python3}
95 %py3_build %{?with_tests:test}
96 %endif
97
98 %if %{with doc}
99 cd docs
100 %{__make} -j1 html
101 rm -rf _build/html/_sources
102 %endif
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106
107 %if %{with python2}
108 %py_install
109
110 %py_postclean
111 %endif
112
113 %if %{with python3}
114 %py3_install
115 %endif
116
117
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %if %{with python2}
123 %files
124 %defattr(644,root,root,755)
125 %doc README.rst LICENSE
126 %{py_sitescriptdir}/flask_script
127 %if "%{py_ver}" > "2.4"
128 %{py_sitescriptdir}/Flask_Script-%{version}-py*.egg-info
129 %endif
130 %endif
131
132 %if %{with python3}
133 %files -n python3-%{module}
134 %defattr(644,root,root,755)
135 %doc README.rst LICENSE
136 %{py3_sitescriptdir}/flask_script
137 %{py3_sitescriptdir}/Flask_Script-%{version}-py*.egg-info
138 %endif
139
140 %if %{with doc}
141 %files apidocs
142 %defattr(644,root,root,755)
143 %doc docs/_build/html/*
144 %endif
This page took 0.075731 seconds and 3 git commands to generate.