]> git.pld-linux.org Git - packages/python-flask-cache.git/blob - python-flask-cache.spec
fbd520e7d14809b5b75cb88166e319e9a066c7f5
[packages/python-flask-cache.git] / python-flask-cache.spec
1 #
2 # Conditional build:
3 %bcond_without  doc             # don't build doc
4 %bcond_without  tests   # do not perform "make test"
5 %bcond_without  python2 # CPython 2.x module
6 %bcond_without  python3 # CPython 3.x module
7
8 %define         module  flask-cache
9 Summary:        Cache support to Flask application
10 Summary(pl.UTF-8):      Wsparcie dla cache w aplikacjach Flask
11 Name:           python-%{module}
12 Version:        0.13.1
13 Release:        7
14 License:        BSD
15 Group:          Libraries/Python
16 Source0:        https://pypi.python.org/packages/source/F/Flask-Cache/Flask-Cache-%{version}.tar.gz
17 # Source0-md5:  ab82a9cd0844891ccdb54fbb93fd6c59
18 URL:            http://github.com/thadeusb/flask-cache
19 BuildRequires:  rpm-pythonprov
20 BuildRequires:  rpmbuild(macros) >= 1.710
21 BuildRequires:  sphinx-pdg
22 %if %{with python2}
23 BuildRequires:  python-distribute
24 %if %{with tests}
25 BuildRequires:  python-flask
26 %endif
27 %endif
28 %if %{with python3}
29 BuildRequires:  python3-modules
30 %if %{with tests}
31 BuildRequires:  python3-flask
32 %endif
33 %endif
34 Requires:       python-modules
35 BuildArch:      noarch
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Cache support to Flask application
40
41 %description -l pl.UTF-8
42 Wsparcie dla cache w aplikacjach Flask
43
44 %package -n python3-%{module}
45 Summary:        Cache support to Flask application
46 Summary(pl.UTF-8):      Wsparcie dla cache w aplikacjach Flask
47 Group:          Libraries/Python
48 Requires:       python3-modules
49
50 %description -n python3-%{module}
51 Cache support to Flask application
52
53 %description -n python3-%{module} -l pl.UTF-8
54 Wsparcie dla cache w aplikacjach Flask
55
56 %package apidocs
57 Summary:        %{module} API documentation
58 Summary(pl.UTF-8):      Dokumentacja API %{module}
59 Group:          Documentation
60
61 %description apidocs
62 API documentation for %{module}.
63
64 %description apidocs -l pl.UTF-8
65 Dokumentacja API %{module}.
66
67 %prep
68 %setup -q -n Flask-Cache-%{version}
69
70 %build
71 %if %{with python2}
72 %py_build %{?with_tests:test}
73 %endif
74
75 %if %{with python3}
76 %py3_build %{?with_tests:test}
77 %endif
78
79 %if %{with doc}
80 cd docs
81 %{__make} -j1 html
82 rm -rf _build/html/_sources
83 %endif
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87
88 %if %{with python2}
89 %py_install
90
91 %py_postclean
92 %endif
93
94 %if %{with python3}
95 %py3_install
96 %endif
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %if %{with python2}
102 %files
103 %defattr(644,root,root,755)
104 %doc CHANGES README LICENSE
105 %{py_sitescriptdir}/flask_cache
106 %if "%{py_ver}" > "2.4"
107 %{py_sitescriptdir}/Flask_Cache-%{version}-py*.egg-info
108 %endif
109 %endif
110
111 %if %{with python3}
112 %files -n python3-%{module}
113 %defattr(644,root,root,755)
114 %doc CHANGES README LICENSE
115 %{py3_sitescriptdir}/flask_cache
116 %{py3_sitescriptdir}/Flask_Cache-%{version}-py*.egg-info
117 %endif
118
119 %if %{with doc}
120 %files apidocs
121 %defattr(644,root,root,755)
122 %doc docs/_build/html/*
123 %endif
This page took 0.074191 seconds and 2 git commands to generate.