]> git.pld-linux.org Git - packages/python-flaky.git/blob - python-flaky.spec
28c1813f25a51f6fc70a26362d9077b68de4ccc1
[packages/python-flaky.git] / python-flaky.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # unit tests (tox required)
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 Summary:        Plugin for nose or pytest that automatically reruns flaky tests
8 Summary(pl.UTF-8):      Wtyczka dla nose lub pytesta automatycznie uruchamiająca ponownie niepewne testy
9 Name:           python-flaky
10 Version:        3.6.1
11 Release:        2
12 License:        Apache v2.0
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.org/simple/flaky/
15 Source0:        https://files.pythonhosted.org/packages/source/f/flaky/flaky-%{version}.tar.gz
16 # Source0-md5:  7427c11cd74e8851f1d7bf2690b646b5
17 URL:            https://pypi.org/project/flaky/
18 %if %{with python2}
19 BuildRequires:  python-modules >= 1:2.7
20 BuildRequires:  python-setuptools
21 %if %{with tests}
22 BuildRequires:  python-pytest
23 BuildRequires:  python-tox
24 %endif
25 %endif
26 %if %{with python3}
27 BuildRequires:  python3-modules >= 1:3.4
28 BuildRequires:  python3-setuptools
29 %if %{with tests}
30 BuildRequires:  python3-pytest
31 BuildRequires:  python3-tox
32 %endif
33 %endif
34 BuildRequires:  rpm-pythonprov
35 BuildRequires:  rpmbuild(macros) >= 1.714
36 Requires:       python-modules >= 1:2.7
37 BuildArch:      noarch
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 Flaky is a plugin for nose or pytest that automatically reruns flaky
42 tests.
43
44 Ideally, tests reliably pass or fail, but sometimes test fixtures must
45 rely on components that aren't 100% reliable. With flaky, instead of
46 removing those tests or marking them to @skip, they can be
47 automatically retried.
48
49 %description -l pl.UTF-8
50 Flaky to wtyczka dla nose lub pytesta automatycznie uruchamiająca
51 ponownie niepewne testy.
52
53 Idealnie testy powinny deterministycznie powodzić się lub nie, ale
54 czasem wypozażenia testów muszą polegać na komponentach nie w pełni
55 deterministycznych. Przy pomocy modułu flaky, zamiast usuwania tych
56 testów lub oznaczania ich @skip, można je automatycznie ponowić.
57
58 %package -n python3-flaky
59 Summary:        Plugin for nose or pytest that automatically reruns flaky tests
60 Summary(pl.UTF-8):      Wtyczka dla nose lub pytesta automatycznie uruchamiająca ponownie niepewne testy
61 Group:          Libraries/Python
62 Requires:       python3-modules >= 1:3.4
63
64 %description -n python3-flaky
65 Flaky is a plugin for nose or pytest that automatically reruns flaky
66 tests.
67
68 Ideally, tests reliably pass or fail, but sometimes test fixtures must
69 rely on components that aren't 100% reliable. With flaky, instead of
70 removing those tests or marking them to @skip, they can be
71 automatically retried.
72
73 %description -n python3-flaky -l pl.UTF-8
74 Flaky to wtyczka dla nose lub pytesta automatycznie uruchamiająca
75 ponownie niepewne testy.
76
77 Idealnie testy powinny deterministycznie powodzić się lub nie, ale
78 czasem wypozażenia testów muszą polegać na komponentach nie w pełni
79 deterministycznych. Przy pomocy modułu flaky, zamiast usuwania tych
80 testów lub oznaczania ich @skip, można je automatycznie ponowić.
81
82 %prep
83 %setup -q -n flaky-%{version}
84
85 %build
86 %if %{with python2}
87 %py_build %{?with_tests:test}
88 %endif
89
90 %if %{with python3}
91 %py3_build %{?with_tests:test}
92 %endif
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96
97 %if %{with python2}
98 %py_install
99
100 %py_postclean
101 %endif
102
103 %if %{with python3}
104 %py3_install
105 %endif
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %if %{with python2}
111 %files
112 %defattr(644,root,root,755)
113 %doc README.rst
114 %{py_sitescriptdir}/flaky
115 %{py_sitescriptdir}/flaky-%{version}-py*.egg-info
116 %endif
117
118 %if %{with python3}
119 %files -n python3-flaky
120 %defattr(644,root,root,755)
121 %doc README.rst
122 %{py3_sitescriptdir}/flaky
123 %{py3_sitescriptdir}/flaky-%{version}-py*.egg-info
124 %endif
This page took 0.202452 seconds and 2 git commands to generate.