]> git.pld-linux.org Git - packages/python-fedmsg-meta-pld.git/blob - python-fedmsg-meta-pld.spec
- release 2 (by relup.sh)
[packages/python-fedmsg-meta-pld.git] / python-fedmsg-meta-pld.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # do not perform "make test"
4
5 %define         module  fedmsg_meta_pld
6 Summary:        Metadata providers for PLD Linux fedmsg deployment
7 Name:           python-fedmsg-meta-pld
8 Version:        0.0.1
9 Release:        2
10 License:        LGPL v2+
11 Group:          Libraries/Python
12 Source0:        https://github.com/glensc/fedmsg_meta_pld/archive/v%{version}/%{module}-%{version}.tar.gz
13 # Source0-md5:  cff6b4aaf192d718632ebd6a2b24bcfc
14 URL:            https://github.com/glensc/fedmsg_meta_pld
15 BuildRequires:  fedmsg >= 0.10.0
16 BuildRequires:  rpm-pythonprov
17 BuildRequires:  rpmbuild(macros) >= 1.219
18 Requires:       fedmsg >= 0.7.7
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Metadata providers for PLD Linux fedmsg deployment.
24
25 %prep
26 %setup -qc
27 mv fedmsg_meta_pld-*/* .
28
29 %build
30 %py_build
31
32 %if %{with tests}
33 PYTHONPATH=. FEDMSG_META_NO_NETWORK=True nosetests
34 %endif
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 %py_install
39 %py_postclean
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %files
45 %defattr(644,root,root,755)
46 %doc README.md CHANGELOG.md
47 %{py_sitescriptdir}/fedmsg_meta_pld
48 %{py_sitescriptdir}/fedmsg_meta_pld-%{version}-py*.egg-info
This page took 0.145716 seconds and 3 git commands to generate.