]> git.pld-linux.org Git - packages/python-faulthandler.git/blob - python-faulthandler.spec
BR: rpmbuild(macros) >= 1.710
[packages/python-faulthandler.git] / python-faulthandler.spec
1 %define module  faulthandler
2 #
3 Summary:        Display the Python traceback on a crash
4 Name:           python-faulthandler
5 Version:        2.3
6 Release:        2
7 License:        BSD
8 Group:          Development/Languages/Python
9 Source0:        http://pypi.python.org/packages/source/f/faulthandler/faulthandler-%{version}.tar.gz
10 # Source0-md5:  76d1344adc2302cf5c59a5f8a4f4f4ae
11 URL:            https://github.com/haypo/faulthandler/wiki
12 BuildRequires:  rpmbuild(macros) >= 1.710
13 BuildRequires:  python-devel
14 BuildRequires:  python-modules
15 BuildRequires:  rpm-pythonprov
16 Requires:       python
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Fault handler for SIGSEGV, SIGFPE, SIGBUS and SIGILL signals: display
21 the Python backtrace and restore the previous handler. Allocate an
22 alternate stack for this handler, if sigaltstack() is available, to be
23 able to allocate memory on the stack, even on stack overflow.
24
25 %prep
26 %setup  -q -n %{module}-%{version}
27
28 %build
29 %py_build --build-base py2
30
31 %install
32 rm -rf $RPM_BUILD_ROOT
33
34 %py_build \
35         --build-base py2 \
36         install \
37         --optimize 2 \
38         --root=$RPM_BUILD_ROOT
39
40 %clean
41 rm -rf $RPM_BUILD_ROOT
42
43 %files
44 %defattr(644,root,root,755)
45 %doc AUTHORS PKG-INFO README TODO
46 %attr(755,root,root) %{py_sitedir}/%{module}.so
47 %{py_sitedir}/*egg-info
This page took 0.044829 seconds and 4 git commands to generate.