]> git.pld-linux.org Git - packages/python-eventlet.git/blob - python-eventlet.spec
rebuild with python 3.10
[packages/python-eventlet.git] / python-eventlet.spec
1 #
2 # Conditional build:
3 %bcond_without  doc             # Sphinx documentation
4 %bcond_with     tests           # unit tests (random timeouts on builders)
5 %bcond_without  python2         # CPython 2.x module
6 %bcond_without  python3         # CPython 3.x module
7
8 Summary:        Highly concurrent networking library for Python 2
9 Summary(pl.UTF-8):      Biblioteka sieciowa o dużym stopniu zrównoleglenia dla Pythona 2
10 Name:           python-eventlet
11 Version:        0.33.0
12 Release:        2
13 License:        MIT
14 Group:          Development/Languages/Python
15 #Source0Download: https://pypi.org/simple/eventlet/
16 Source0:        https://files.pythonhosted.org/packages/source/e/eventlet/eventlet-%{version}.tar.gz
17 # Source0-md5:  a15ae1b585678c0bad0e89916d7c0ab4
18 URL:            https://pypi.org/project/eventlet/
19 BuildRequires:  rpm-pythonprov
20 BuildRequires:  rpmbuild(macros) >= 1.714
21 %if %{with python2}
22 BuildRequires:  python-devel >= 1:2.7
23 BuildRequires:  python-setuptools >= 1:5.4.1
24 %if %{with tests}
25 BuildRequires:  python-dns >= 1.15.0
26 BuildRequires:  python-enum34
27 BuildRequires:  python-greenlet >= 0.3
28 BuildRequires:  python-monotonic >= 1.4
29 BuildRequires:  python-nose >= 1.3.1
30 BuildRequires:  python-six >= 1.10.0
31 BuildRequires:  python-subprocess32
32 %endif
33 %endif
34 %if %{with python3}
35 BuildRequires:  python3-devel >= 1:3.5
36 BuildRequires:  python3-setuptools >= 1:5.4.1
37 %if %{with tests}
38 BuildRequires:  python3-dns >= 1.15.0
39 BuildRequires:  python3-greenlet >= 0.3
40 BuildRequires:  python3-nose >= 1.3.1
41 BuildRequires:  python3-six >= 1.10.0
42 %endif
43 %endif
44 %{?with_doc:BuildRequires:      sphinx-pdg}
45 %if %{with tests}
46 # SO_REUSEPORT option for tests.convenience_test.test_socket_reuse
47 BuildRequires:  uname(release) >= 3.9
48 %endif
49 Requires:       python-modules >= 1:2.7
50 BuildArch:      noarch
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %description
54 Eventlet is a concurrent networking library for Python that allows you
55 to change how you run your code, not how you write it.
56
57 It uses epoll or libevent for highly scalable non-blocking I/O.
58 Coroutines ensure that the developer uses a blocking style of
59 programming that is similar to threading, but provide the benefits of
60 non-blocking I/O. The event dispatch is implicit, which means you can
61 easily use Eventlet from the Python interpreter, or as a small part of
62 a larger application.
63
64 %description -l pl.UTF-8
65 Eventlet to równoległa biblioteka sieciowa dla Ptyhona, pozwalająca na
66 zmianę sposobu uruchamiania kodu bez sposobu pisania go.
67
68 Biblioteka wykorzystuje epoll lub libevent do wysoko skalowalnych,
69 nieblokujących operacji we/wy. Korutyny zapewniają, że programista
70 korzysta z blokującego stylu programowania, podobnego do wątkowego,
71 ale mającego zalety nieblokującego we/wy. Przekazywania zdarzeń jest
72 domyślne, co oznacza, że można łatwo używać modułu Eventlet z poziomu
73 interpretera Pythona lub jako małej części dużej aplikacji.
74
75 %package -n python3-eventlet
76 Summary:        Highly concurrent networking library for Python 3
77 Summary(pl.UTF-8):      Biblioteka sieciowa o dużym stopniu zrównoleglenia dla Pythona 3
78 Group:          Development/Languages/Python
79 Requires:       python3-modules >= 1:3.5
80
81 %description -n python3-eventlet
82 Eventlet is a concurrent networking library for Python that allows you
83 to change how you run your code, not how you write it.
84
85 It uses epoll or libevent for highly scalable non-blocking I/O.
86 Coroutines ensure that the developer uses a blocking style of
87 programming that is similar to threading, but provide the benefits of
88 non-blocking I/O. The event dispatch is implicit, which means you can
89 easily use Eventlet from the Python interpreter, or as a small part of
90 a larger application.
91
92 %description -n python3-eventlet -l pl.UTF-8
93 Eventlet to równoległa biblioteka sieciowa dla Ptyhona, pozwalająca na
94 zmianę sposobu uruchamiania kodu bez sposobu pisania go.
95
96 Biblioteka wykorzystuje epoll lub libevent do wysoko skalowalnych,
97 nieblokujących operacji we/wy. Korutyny zapewniają, że programista
98 korzysta z blokującego stylu programowania, podobnego do wątkowego,
99 ale mającego zalety nieblokującego we/wy. Przekazywania zdarzeń jest
100 domyślne, co oznacza, że można łatwo używać modułu Eventlet z poziomu
101 interpretera Pythona lub jako małej części dużej aplikacji.
102
103 %package apidocs
104 Summary:        API documentation for eventlet module
105 Summary(pl.UTF-8):      Dokumentacja API modułu eventlet
106 Group:          Documentation
107 BuildArch:      noarch
108
109 %description apidocs
110 API documentation for eventlet module.
111
112 %description apidocs -l pl.UTF-8
113 Dokumentacja API modułu eventlet.
114
115 %prep
116 %setup -q -n eventlet-%{version}
117
118 # uses network
119 %{__rm} tests/greendns_test.py
120 # requires local mysql
121 %{__rm} tests/mysqldb_test.py
122
123 %build
124 %if %{with python2}
125 %py_build
126
127 %if %{with tests}
128 PYTHONPATH=$(pwd) \
129 nosetests-%{py_ver} tests
130 %endif
131 %endif
132
133 %if %{with python3}
134 %py3_build
135
136 %if %{with tests}
137 PYTHONPATH=$(pwd) \
138 nosetests-%{py3_ver} tests
139 %endif
140 %endif
141
142 %if %{with doc}
143 PYTHONPATH=$(pwd) \
144 %{__make} -C doc -j1 html
145 %endif
146
147 %install
148 rm -rf $RPM_BUILD_ROOT
149
150 %if %{with python2}
151 %py_install
152
153 %py_postclean
154 %endif
155
156 %if %{with python3}
157 %py3_install
158 %endif
159
160 %clean
161 rm -rf $RPM_BUILD_ROOT
162
163 %if %{with python2}
164 %files
165 %defattr(644,root,root,755)
166 %doc AUTHORS LICENSE NEWS README.rst
167 %{py_sitescriptdir}/eventlet
168 %{py_sitescriptdir}/eventlet-%{version}-py*.egg-info
169 %endif
170
171 %if %{with python3}
172 %files -n python3-eventlet
173 %defattr(644,root,root,755)
174 %doc AUTHORS LICENSE NEWS README.rst
175 %{py3_sitescriptdir}/eventlet
176 %{py3_sitescriptdir}/eventlet-%{version}-py*.egg-info
177 %endif
178
179 %if %{with doc}
180 %files apidocs
181 %defattr(644,root,root,755)
182 %doc doc/_build/html/{_images,_static,modules,*.html,*.js}
183 %endif
This page took 0.161622 seconds and 3 git commands to generate.