]> git.pld-linux.org Git - packages/python-enet.git/blob - python-enet.spec
new, version 0.0.0 at svn rev24
[packages/python-enet.git] / python-enet.spec
1 # No releases, source only available through svn.
2 # svn co http://pyenet.googlecode.com/svn/trunk/ pyenet-trunk-svn24
3 %define         module  pyenet
4 %define         svnrev  svn24
5 %define         rel             1
6 Summary:        Python bindings for ENet
7 Name:           python-enet
8 Version:        0.0.0
9 Release:        0.%{svnrev}.%{rel}
10 License:        MIT
11 Group:          Libraries/Python
12 URL:            http://code.google.com/p/pyenet
13 Source0:        %{module}-trunk-%{svnrev}.tar.bz2
14 # Source0-md5:  1fa3e0ff41974fee2defc88d03a1c293
15 Patch0:         pyenet-build-against-system-enet.patch
16 BuildRequires:  enet-devel >= 1.3.3
17 BuildRequires:  python-Cython >= 0.13
18 BuildRequires:  python-devel
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Pyenet was written originally by Scott Robinson <scott@tranzoa.com>.
23
24 It's currently maintained by Andrew Resch <andrewresch@gmail.com> and
25 provides the Python bindings for ENet.
26
27 %prep
28 %setup -q -n %{module}-trunk-%{svnrev}
29 %patch0 -p1
30
31 %build
32 CC="%{__cc}" \
33 CFLAGS="%{rpmcflags}" \
34 %{__python} setup.py build
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 %{__python} setup.py install \
39         --skip-build \
40         --optimize=2 \
41         --root=$RPM_BUILD_ROOT
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %files
47 %defattr(644,root,root,755)
48 %doc LICENSE README ChangeLog
49 %attr(755,root,root) %{py_sitedir}/enet.so
50 %{py_sitedir}/enet-%{version}-py*.egg-info
This page took 0.077104 seconds and 3 git commands to generate.