]> git.pld-linux.org Git - packages/python-elixir.git/blob - python-elixir.spec
sqlalchemy 0.8+ fix
[packages/python-elixir.git] / python-elixir.spec
1 %define         module elixir
2 Summary:        Declarative layer on top of the SQLAlchemy library
3 Summary(pl.UTF-8):      Warstwa nad biblioteką SQLAlchemy.
4 Name:           python-%{module}
5 Version:        0.7.1
6 Release:        4
7 License:        MIT
8 Group:          Development/Languages/Python
9 Source0:        https://pypi.python.org/packages/source/E/Elixir/Elixir-%{version}.tar.gz
10 # Source0-md5:  5615ec9693e3a8e44f69623d58f54116
11 Patch0:         sqlalchemy-0.8.patch
12 URL:            http://elixir.ematia.de/trac/wiki
13 BuildRequires:  python-setuptools
14 BuildRequires:  rpm-pythonprov
15 BuildRequires:  rpmbuild(macros) >= 1.219
16 Requires:       python-sqlalchemy >= 0.8
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 A declarative layer on top of SQLAlchemy. It is a fairly thin wrapper,
22 which provides the ability to create simple Python classes that map
23 directly to relational database tables (this pattern is often referred
24 to as the Active Record design pattern), providing many of the
25 benefits of traditional databases without losing the convenience of
26 Python objects.
27
28 %description -l pl.UTF-8
29 Cienka dodatkowa warstwa ponad SQLAlchemy. Pozwala tworzyć proste
30 klasy Pythonowe bezpośrednio mapowane do tabel relacyjnej bazy danych
31 (często nazywane też wzorcem projektowym Active Record) dając wiele z
32 zalet tradycyjnych baz danych bez straty wygody obiektów Pythonowych.
33
34 %prep
35 %setup -q -n Elixir-%{version}
36 %patch0 -p1
37
38 %build
39 CFLAGS="%{rpmcflags}" \
40 %{__python} setup.py build
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 %{__python} setup.py install \
45         --optimize=2 \
46         --root=$RPM_BUILD_ROOT
47
48 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
49 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
50 %py_postclean
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %{py_sitescriptdir}/elixir
58 %{py_sitescriptdir}/Elixir-%{version}-py*.egg-info
This page took 0.043009 seconds and 3 git commands to generate.