]> git.pld-linux.org Git - packages/python-elixir.git/blob - python-elixir.spec
4d9f82235f4ca53a10ce4dc93b6e8398b8bfad7c
[packages/python-elixir.git] / python-elixir.spec
1 %define         module elixir
2 Summary:        Declarative layer on top of the SQLAlchemy library
3 Summary(pl.UTF-8):      Warstwa nad biblioteką SQLAlchemy.
4 Name:           python-%{module}
5 Version:        0.7.1
6 Release:        3
7 License:        MIT
8 Group:          Development/Languages/Python
9 Source0:        http://pypi.python.org/packages/source/E/Elixir/Elixir-%{version}.tar.gz
10 # Source0-md5:  5615ec9693e3a8e44f69623d58f54116
11 URL:            http://elixir.ematia.de/trac/wiki
12 BuildRequires:  python-setuptools
13 BuildRequires:  rpm-pythonprov
14 BuildRequires:  rpmbuild(macros) >= 1.219
15 Requires:       python-SQLAlchemy
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 A declarative layer on top of SQLAlchemy. It is a fairly thin wrapper,
21 which provides the ability to create simple Python classes that map
22 directly to relational database tables (this pattern is often referred
23 to as the Active Record design pattern), providing many of the
24 benefits of traditional databases without losing the convenience of
25 Python objects.
26
27 %description -l pl.UTF-8
28 Cienka dodatkowa warstwa ponad SQLAlchemy. Pozwala tworzyć proste
29 klasy Pythonowe bezpośrednio mapowane do tabel relacyjnej bazy danych
30 (często nazywane też wzorcem projektowym Active Record) dając wiele z
31 zalet tradycyjnych baz danych bez straty wygody obiektów Pythonowych.
32
33 %prep
34 %setup -q -n Elixir-%{version}
35
36 %build
37 CFLAGS="%{rpmcflags}" \
38 %{__python} setup.py build
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 %{__python} setup.py install \
43         --optimize=2 \
44         --root=$RPM_BUILD_ROOT
45
46 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
47 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
48 %py_postclean
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %{py_sitescriptdir}/elixir
56 %{py_sitescriptdir}/Elixir-%{version}-py*.egg-info
This page took 0.043399 seconds and 2 git commands to generate.