]> git.pld-linux.org Git - packages/python-elementary.git/blob - python-elementary.spec
a34b69beadb326f8bbdbb9ff6b832b8cc45b5676
[packages/python-elementary.git] / python-elementary.spec
1 Summary:        Python bindings for Elementary library
2 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki Elementary
3 Name:           python-elementary
4 Version:        1.7.0
5 Release:        3
6 License:        LGPL v3+
7 Group:          Development/Languages/Python
8 Source0:        http://download.enlightenment.org/releases/BINDINGS/python/%{name}-%{version}.tar.bz2
9 # Source0-md5:  38c8b2ac508ab4e1d12f1557a12169c9
10 URL:            http://trac.enlightenment.org/e/wiki/Python
11 BuildRequires:  elementary-devel >= 1.7.0
12 BuildRequires:  eina-devel >= 1.7.0
13 BuildRequires:  epydoc
14 BuildRequires:  evas-devel >= 1.7.0
15 BuildRequires:  python-Cython >= 0.15.1
16 BuildRequires:  python-devel >= 1:2.7
17 BuildRequires:  python-evas >= 1.7.0
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  pkgconfig >= 1:0.22
20 BuildRequires:  rpmbuild(macros) >= 1.219
21 Requires:       elementary-libs >= 1.7.0
22 Requires:       eina >= 1.7.0
23 Requires:       evas >= 1.7.0
24 Requires:       python-evas >= 1.7.0
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Python bindings for Elementary library.
29
30 %description -l pl.UTF-8
31 Wiązania Pythona do biblioteki Elementary.
32
33 %package devel
34 Summary:        Python bindings for Elementary library - development files
35 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki Elementary - pliki programistyczne
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38 Requires:       elementary-devel >= 1.7.0
39 Requires:       eina-devel >= 1.7.0
40 Requires:       evas-devel >= 1.7.0
41 Requires:       python-evas-devel >= 1.7.0
42
43 %description devel
44 Python bindings for Elementary library - development files.
45
46 %description devel -l pl.UTF-8
47 Wiązania Pythona do biblioteki Elementary - pliki programistyczne.
48
49 %prep
50 %setup -q
51
52 %build
53 %configure \
54         --disable-silent-rules
55
56 %{__make}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 %py_postclean
65 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/elementary/c_elementary.la
66
67 install -d $RPM_BUILD_ROOT%{_examplesdir}
68 mv $RPM_BUILD_ROOT%{_datadir}/%{name}/examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc AUTHORS ChangeLog README
76 %dir %{py_sitedir}/elementary
77 %attr(755,root,root) %{py_sitedir}/elementary/c_elementary.so
78 %{py_sitedir}/elementary/*.py[co]
79 %{_examplesdir}/%{name}-%{version}
80
81 %files devel
82 %defattr(644,root,root,755)
83 %{_pkgconfigdir}/python-elementary.pc
This page took 0.209638 seconds and 2 git commands to generate.