]> git.pld-linux.org Git - packages/python-efl.git/blob - python-efl.spec
1ead056abb115f8067f17d82a3804529eb808f25
[packages/python-efl.git] / python-efl.spec
1 %define         efl_ver         1.10.0
2 %define         ecore_ver       %{efl_ver}
3 %define         edje_ver        %{efl_ver}
4 %define         eina_ver        %{efl_ver}
5 %define         emotion_ver     %{efl_ver}
6 %define         eo_ver          %{efl_ver}
7 %define         ethumb_ver      %{efl_ver}
8 %define         evas_ver        %{efl_ver}
9 %define         elementary_ver  1.10.0
10 %define         py_dbus_ver     0.83.0
11
12 Summary:        Python bindings for Enlightenment Foundation Libraries
13 Summary(pl.UTF-8):      Wiązania Pythona do bibliotek EFL (Enlightenment Foundation Libraries)
14 Name:           python-efl
15 Version:        1.10.1
16 Release:        3
17 License:        LGPL v3+
18 Group:          Development/Languages/Python
19 Source0:        http://download.enlightenment.org/rel/bindings/python/%{name}-%{version}.tar.bz2
20 # Source0-md5:  5f95d3ee5c4bb2a1a616d44d0cc5f0d0
21 Patch0:         %{name}-cython.patch
22 URL:            http://trac.enlightenment.org/e/wiki/Python
23 BuildRequires:  python-dbus-devel >= %{py_dbus_ver}
24 BuildRequires:  ecore-devel >= %{ecore_ver}
25 BuildRequires:  ecore-file-devel >= %{ecore_ver}
26 BuildRequires:  ecore-input-devel >= %{ecore_ver}
27 BuildRequires:  ecore-x-devel >= %{ecore_ver}
28 BuildRequires:  edje-devel >= %{edje_ver}
29 BuildRequires:  eina-devel >= %{eina_ver}
30 BuildRequires:  elementary-devel >= %{elementary_ver}
31 BuildRequires:  emotion-devel >= %{emotion_ver}
32 BuildRequires:  eo-devel >= %{eo_ver}
33 BuildRequires:  ethumb-devel >= %{ethumb_ver}
34 BuildRequires:  evas-devel >= %{evas_ver}
35 BuildRequires:  pkgconfig
36 # when using *.pyx sources, not pregenerated *.c
37 #BuildRequires: python-Cython >= 0.19
38 BuildRequires:  python-Sphinx
39 BuildRequires:  python-devel >= 1:2.7
40 BuildRequires:  rpm-pythonprov
41 BuildRequires:  rpmbuild(macros) >= 1.710
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 EFL is a collection of libraries for handling many common tasks a
46 developer man have such as data structures, communication, rendering,
47 widgets and more. PYTHON-EFL are the Python bindings for EFL and
48 Elementary.
49
50 %description -l pl.UTF-8
51 EFL to zbiór bibliotek do obsługi wielu częstych zadań programisty,
52 takich jak struktury danych, komunikacja, renderowanie, widgety itp.
53 PYTHON-EFL to wiązania Pythona do bibliotek EFL i Elementary.
54
55 %package base
56 Summary:        Python bindings for Enlightenment Foundation Libraries - base common part
57 Summary(pl.UTF-8):      Wiązania Pythona do bibliotek EFL - wspólna część podstawowa
58 Group:          Development/Languages/Python
59 Requires:       eina >= %{eina_ver}
60 Requires:       eo >= %{eina_ver}
61
62 %description base
63 Python bindings for Enlightenment Foundation Libraries - base common
64 part:
65 - Eo library binding
66 - efl.utils modules
67
68 %description base
69 Wiązania Pythona do bibliotek EFL (Enlightenment Foundation Libraries)
70 - wspólna część podstawowa:
71 - wiązanie do biblioteki Eo
72 - moduły efl.utils
73
74 %package examples
75 Summary:        Examples for PYTHON-EFL bindings
76 Summary(pl.UTF-8):      Przykłady do wiązań PYTHON-EFL
77 Group:          Development/Libraries
78 Requires:       python-dbus >= %{py_dbus_ver}
79 Requires:       python-e_dbus = %{version}-%{release}
80 Requires:       python-ecore = %{version}-%{release}
81 Requires:       python-ecore-x = %{version}-%{release}
82 Requires:       python-edje = %{version}-%{release}
83 Requires:       python-elementary = %{version}-%{release}
84 Requires:       python-emotion = %{version}-%{release}
85 Requires:       python-evas = %{version}-%{release}
86
87 %description examples
88 Examples for PYTHON-EFL bindings.
89
90 %description examples -l pl.UTF-8
91 Przykłady do wiązań PYTHON-EFL.
92
93 %package -n python-e_dbus
94 Summary:        D-Bus Python integration for Ecore main loop
95 Summary(pl.UTF-8):      Integracja Python i DBus z główną pętlą Ecore
96 Group:          Development/Languages/Python
97 Requires:       %{name}-base = %{version}-%{release}
98 Requires:       ecore >= %{ecore_ver}
99 Obsoletes:      python-e_dbus < 1.8.0
100 Obsoletes:      python-e_dbus-devel < 1.8.0
101
102 %description -n python-e_dbus
103 D-Bus Python integration for Ecore main loop. There is also e_dbus
104 API provided for compatibility with EFL 1.7.0 bindings.
105
106 %description -n python-e_dbus -l pl.UTF-8
107 Integracja Python i DBus z główną pętlą Ecore. Dołączone jest także
108 API e_dbus dla kompatybilności z wiązaniami EFL 1.7.0.
109
110 %package -n python-ecore
111 Summary:        Python bindings for Ecore library
112 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki Ecore
113 Group:          Development/Languages/Python
114 Requires:       %{name}-base = %{version}-%{release}
115 Requires:       ecore >= %{ecore_ver}
116 Requires:       ecore-file >= %{ecore_ver}
117 Obsoletes:      python-ecore-devel < 1.8.0
118 Obsoletes:      python-ecore-evas < 1.8.0
119 Obsoletes:      python-ecore-evas-devel < 1.8.0
120 Obsoletes:      python-ecore-file < 1.8.0
121 Obsoletes:      python-ecore-file-devel < 1.8.0
122 Obsoletes:      python-ecore-imf < 1.8.0
123 Obsoletes:      python-ecore-imf-devel < 1.8.0
124
125 %description -n python-ecore
126 Python bindings for Ecore library.
127
128 %description -n python-ecore -l pl.UTF-8
129 Wiązania Pythona do biblioteki Ecore.
130
131 %package -n python-ecore-x
132 Summary:        Python bindings for Ecore X library
133 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki Ecore X
134 Group:          Development/Languages/Python
135 Requires:       python-ecore = %{version}-%{release}
136 Requires:       ecore-input >= %{ecore_ver}
137 Requires:       ecore-x >= %{ecore_ver}
138 Obsoletes:      python-ecore-x-devel < 1.8.0
139
140 %description -n python-ecore-x
141 Python bindings for Ecore X library.
142
143 %description -n python-ecore-x -l pl.UTF-8
144 Wiązania Pythona do biblioteki Ecore X.
145
146 %package -n python-edje
147 Summary:        Python bindings for Edje library
148 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki Edje
149 Group:          Development/Languages/Python
150 Requires:       %{name}-base = %{version}-%{release}
151 Requires:       edje-libs >= %{edje_ver}
152 Requires:       eina >= %{eina_ver}
153 Obsoletes:      python-edje-devel < 1.8.0
154
155 %description -n python-edje
156 Python bindings for Edje library.
157
158 %description -n python-edje -l pl.UTF-8
159 Wiązania Pythona do biblioteki Edje.
160
161 %package -n python-elementary
162 Summary:        Python bindings for Elementary library
163 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki Elementary
164 Group:          Development/Languages/Python
165 Requires:       %{name}-base = %{version}-%{release}
166 Requires:       eina >= %{eina_ver}
167 Requires:       elementary-libs >= %{elementary_ver}
168 Requires:       evas >= %{evas_ver}
169 Obsoletes:      python-elementary-devel < 1.8.0
170
171 %description -n python-elementary
172 Python bindings for Elementary library.
173
174 %description -n python-elementary -l pl.UTF-8
175 Wiązania Pythona do biblioteki Elementary.
176
177 %package -n python-emotion
178 Summary:        Python bindings for Emotion library
179 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki Emotion
180 Group:          Development/Languages/Python
181 Requires:       %{name}-base = %{version}-%{release}
182 Requires:       emotion >= %{emotion_ver}
183 Requires:       evas >= %{evas_ver}
184 Obsoletes:      python-emotion-devel < 1.8.0
185
186 %description -n python-emotion
187 Python bindings for Emotion library.
188
189 %description -n python-emotion -l pl.UTF-8
190 Wiązania Pythona do biblioteki Emotion.
191
192 %package -n python-ethumb
193 Summary:        Python bindings for Ethumb library
194 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki Ethumb
195 Group:          Development/Languages/Python
196 Requires:       %{name}-base = %{version}-%{release}
197 Requires:       ethumb-libs >= %{ethumb_ver}
198 Obsoletes:      python-ethumb-devel < 1.8.0
199
200 %description -n python-ethumb
201 Python bindings for Ethumb library.
202
203 %description -n python-ethumb -l pl.UTF-8
204 Wiązania Pythona do biblioteki Ethumb.
205
206 %package -n python-evas
207 Summary:        Python bindings for Evas library
208 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki Evas
209 Group:          Development/Languages/Python
210 Requires:       %{name}-base = %{version}-%{release}
211 Requires:       eina >= %{eina_ver}
212 Requires:       evas >= %{evas_ver}
213 Obsoletes:      python-evas-devel < 1.8.0
214
215 %description -n python-evas
216 Python bindings for Evas library.
217
218 %description -n python-evas -l pl.UTF-8
219 Wiązania Pythona do biblioteki Evas.
220
221 %prep
222 %setup -q
223 %patch0 -p1
224
225 %{__sed} -i -e '1s,/usr/bin/env python,/usr/bin/python,' \
226         examples/dbus/*.py \
227         examples/elementary/*.py \
228         examples/emotion/*.py \
229
230 %build
231 CC="%{__cc}" \
232 CFLAGS="%{rpmcflags}" \
233 DISABLE_CYTHON=1 \
234 %py_build
235
236 %install
237 rm -rf $RPM_BUILD_ROOT
238
239 DISABLE_CYTHON=1 \
240 %py_install
241
242 %py_postclean
243
244 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
245 cp -pr examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
246
247 %clean
248 rm -rf $RPM_BUILD_ROOT
249
250 %files base
251 %defattr(644,root,root,755)
252 %doc AUTHORS README.rst changes.html
253 %dir %{py_sitedir}/efl
254 %{py_sitedir}/efl/__init__.py[co]
255 %attr(755,root,root) %{py_sitedir}/efl/eo.so
256 %dir %{py_sitedir}/efl/utils
257 %{py_sitedir}/efl/utils/__init__.py[co]
258 %attr(755,root,root) %{py_sitedir}/efl/utils/*.so
259 %{py_sitedir}/python_efl-%{version}-py*.egg-info
260
261 %files examples
262 %defattr(644,root,root,755)
263 %dir %{_examplesdir}/%{name}-%{version}
264 %dir %{_examplesdir}/%{name}-%{version}/dbus
265 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/dbus/*.py
266 %dir %{_examplesdir}/%{name}-%{version}/ecore
267 %dir %{_examplesdir}/%{name}-%{version}/ecore/x
268 %{_examplesdir}/%{name}-%{version}/ecore/x/*.py
269 %dir %{_examplesdir}/%{name}-%{version}/elementary
270 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/elementary/test.py
271 %{_examplesdir}/%{name}-%{version}/elementary/test_*.py
272 %{_examplesdir}/%{name}-%{version}/elementary/*.edc
273 %{_examplesdir}/%{name}-%{version}/elementary/*.edj
274 %{_examplesdir}/%{name}-%{version}/elementary/images
275 %dir %{_examplesdir}/%{name}-%{version}/emotion
276 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/emotion/test_emotion.py
277 %{_examplesdir}/%{name}-%{version}/emotion/theme.edj
278
279 %files -n python-e_dbus
280 %defattr(644,root,root,755)
281 %attr(755,root,root) %{py_sitedir}/efl/dbus_mainloop.so
282 %{py_sitedir}/e_dbus
283
284 %files -n python-ecore
285 %defattr(644,root,root,755)
286 %dir %{py_sitedir}/efl/ecore
287 %attr(755,root,root) %{py_sitedir}/efl/ecore/__init__.so
288 %{py_sitedir}/efl/ecore/__init__.py[co]
289 %{py_sitedir}/ecore
290
291 %files -n python-ecore-x
292 %defattr(644,root,root,755)
293 %attr(755,root,root) %{py_sitedir}/efl/ecore/x.so
294
295 %files -n python-edje
296 %defattr(644,root,root,755)
297 %attr(755,root,root) %{py_sitedir}/efl/edje.so
298 %attr(755,root,root) %{py_sitedir}/efl/edje_edit.so
299 %{py_sitedir}/edje
300
301 %files -n python-elementary
302 %defattr(644,root,root,755)
303 %dir %{py_sitedir}/efl/elementary
304 %{py_sitedir}/efl/elementary/__init__.py[co]
305 %attr(755,root,root) %{py_sitedir}/efl/elementary/*.so
306 %{py_sitedir}/elementary
307
308 %files -n python-emotion
309 %defattr(644,root,root,755)
310 %attr(755,root,root) %{py_sitedir}/efl/emotion.so
311 %{py_sitedir}/emotion
312
313 %files -n python-ethumb
314 %defattr(644,root,root,755)
315 %attr(755,root,root) %{py_sitedir}/efl/ethumb.so
316 %attr(755,root,root) %{py_sitedir}/efl/ethumb_client.so
317
318 %files -n python-evas
319 %defattr(644,root,root,755)
320 %attr(755,root,root) %{py_sitedir}/efl/evas.so
321 %{py_sitedir}/evas
This page took 0.057494 seconds and 2 git commands to generate.