]> git.pld-linux.org Git - packages/python-ecdsa.git/blob - python-ecdsa.spec
bf9340d98794b592b1e500b9fcd39be9b93ff57b
[packages/python-ecdsa.git] / python-ecdsa.spec
1 #
2 # Conditional build:
3 %bcond_without  python2         # Python 2.x module
4 %bcond_without  python3         # Python 3.x module
5
6 %define         module  ecdsa
7 Summary:        ECDSA cryptographic signature library
8 Summary(pl.UTF-8):      Biblioteka podpisów kryptograficznych ECDSA
9 Name:           python-%{module}
10 Version:        0.13
11 Release:        3
12 License:        MIT
13 Group:          Development/Languages/Python
14 #Source0Download: https://pypi.python.org/simple/ecdsa/
15 Source0:        https://pypi.python.org/packages/source/e/ecdsa/%{module}-%{version}.tar.gz
16 # Source0-md5:  1f60eda9cb5c46722856db41a3ae6670
17 URL:            https://pypi.python.org/pypi/ecdsa
18 BuildRequires:  rpmbuild(macros) >= 1.714
19 BuildRequires:  rpm-pythonprov
20 %if %{with python2}
21 BuildRequires:  python-devel >= 1:2.6
22 BuildRequires:  python-modules >= 1:2.6
23 %endif
24 %if %{with python3}
25 BuildRequires:  python3-2to3 >= 1:3.2
26 BuildRequires:  python3-devel >= 1:3.2
27 BuildRequires:  python3-modules >= 1:3.2
28 %endif
29 Requires:       python-modules >= 1:2.6
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 This is an easy-to-use implementation of ECDSA cryptography (Elliptic
35 Curve Digital Signature Algorithm), implemented purely in Python,
36 released under the MIT license. With this library, you can quickly
37 create keypairs (signing key and verifying key), sign messages, and
38 verify the signatures. The keys and signatures are very short, making
39 them easy to handle and incorporate into other protocols.
40
41 %description -l pl.UTF-8
42 Ten moduł to implementacja kryptografii ECDSA (Elliptic Curve Digital
43 Signature Algorytm - algorytmu podpisu cyfrowego opartego na krzywych
44 eliptycznych) w czystym Pythonie, wydana na licencji MIT. Przy użyciu
45 tej biblioteki można szybko tworzyć pary kluczy (podpisujący i
46 weryfikujący), podpisywać wiadomości oraz sprawdzać podpisy. Klucze i
47 podpisy są bardzo krótkie, co czyni je łatwymi do obsłużenia i
48 włączenia do innych protokołów.
49
50 %package -n python3-%{module}
51 Summary:        ECDSA cryptographic signature library
52 Summary(pl.UTF-8):      Biblioteka podpisów kryptograficznych ECDSA
53 Group:          Libraries/Python
54 Requires:       python3-modules >= 1:3.2
55
56 %description -n python3-%{module}
57 This is an easy-to-use implementation of ECDSA cryptography (Elliptic
58 Curve Digital Signature Algorithm), implemented purely in Python,
59 released under the MIT license. With this library, you can quickly
60 create keypairs (signing key and verifying key), sign messages, and
61 verify the signatures. The keys and signatures are very short, making
62 them easy to handle and incorporate into other protocols.
63
64 %description -n python3-%{module} -l pl.UTF-8
65 Ten moduł to implementacja kryptografii ECDSA (Elliptic Curve Digital
66 Signature Algorytm - algorytmu podpisu cyfrowego opartego na krzywych
67 eliptycznych) w czystym Pythonie, wydana na licencji MIT. Przy użyciu
68 tej biblioteki można szybko tworzyć pary kluczy (podpisujący i
69 weryfikujący), podpisywać wiadomości oraz sprawdzać podpisy. Klucze i
70 podpisy są bardzo krótkie, co czyni je łatwymi do obsłużenia i
71 włączenia do innych protokołów.
72
73 %prep
74 %setup  -q -n ecdsa-%{version}
75
76 %build
77 %if %{with python2}
78 %py_build
79 %endif
80
81 %if %{with python3}
82 %py3_build
83 %endif
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87
88 %if %{with python2}
89 install -d $RPM_BUILD_ROOT%{_examplesdir}/python-%{module}-%{version}
90 %py_install
91 %endif
92
93 %if %{with python3}
94 install -d $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version}
95 %py3_install
96 %endif
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %if %{with python2}
102 %files
103 %defattr(644,root,root,755)
104 %doc LICENSE NEWS README.md
105 %{py_sitescriptdir}/%{module}
106 %{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
107 %{_examplesdir}/python-%{module}-%{version}
108 %endif
109
110 %if %{with python3}
111 %files -n python3-%{module}
112 %defattr(644,root,root,755)
113 %doc LICENSE NEWS README.md
114 %{py3_sitescriptdir}/%{module}
115 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
116 %{_examplesdir}/python3-%{module}-%{version}
117 %endif
This page took 0.029544 seconds and 2 git commands to generate.