]> git.pld-linux.org Git - packages/python-ecdsa.git/blob - python-ecdsa.spec
06327a4b8127b9316c14e09ffdef471677cc6d7d
[packages/python-ecdsa.git] / python-ecdsa.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 %bcond_without  python2 # Python 2.x module
5 %bcond_without  python3 # Python 3.x module
6
7 %define         module  ecdsa
8 Summary:        ECDSA cryptographic signature library
9 Summary(pl.UTF-8):      Biblioteka podpisów kryptograficznych ECDSA
10 Name:           python-%{module}
11 Version:        0.16.1
12 Release:        3
13 License:        MIT
14 Group:          Development/Languages/Python
15 #Source0Download: https://pypi.org/simple/ecdsa/
16 Source0:        https://files.pythonhosted.org/packages/source/e/ecdsa/%{module}-%{version}.tar.gz
17 # Source0-md5:  98c0da4c046286e892fdba727f93edea
18 URL:            https://pypi.org/project/ecdsa
19 BuildRequires:  rpmbuild(macros) >= 1.714
20 BuildRequires:  rpm-pythonprov
21 %if %{with python2}
22 BuildRequires:  python-devel >= 1:2.6
23 BuildRequires:  python-modules >= 1:2.6
24 BuildRequires:  python-setuptools
25 %if %{with tests}
26 BuildRequires:  python-hypothesis
27 BuildRequires:  python-pytest
28 BuildRequires:  python-six >= 1.9.0
29 %endif
30 %endif
31 %if %{with python3}
32 BuildRequires:  python3-devel >= 1:3.3
33 BuildRequires:  python3-modules >= 1:3.3
34 BuildRequires:  python3-setuptools
35 %if %{with tests}
36 BuildRequires:  python3-hypothesis
37 BuildRequires:  python3-pytest
38 BuildRequires:  python3-six >= 1.9.0
39 %endif
40 %endif
41 Requires:       python-modules >= 1:2.6
42 BuildArch:      noarch
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 This is an easy-to-use implementation of ECDSA cryptography (Elliptic
47 Curve Digital Signature Algorithm), implemented purely in Python,
48 released under the MIT license. With this library, you can quickly
49 create keypairs (signing key and verifying key), sign messages, and
50 verify the signatures. The keys and signatures are very short, making
51 them easy to handle and incorporate into other protocols.
52
53 %description -l pl.UTF-8
54 Ten moduł to implementacja kryptografii ECDSA (Elliptic Curve Digital
55 Signature Algorytm - algorytmu podpisu cyfrowego opartego na krzywych
56 eliptycznych) w czystym Pythonie, wydana na licencji MIT. Przy użyciu
57 tej biblioteki można szybko tworzyć pary kluczy (podpisujący i
58 weryfikujący), podpisywać wiadomości oraz sprawdzać podpisy. Klucze i
59 podpisy są bardzo krótkie, co czyni je łatwymi do obsłużenia i
60 włączenia do innych protokołów.
61
62 %package -n python3-%{module}
63 Summary:        ECDSA cryptographic signature library
64 Summary(pl.UTF-8):      Biblioteka podpisów kryptograficznych ECDSA
65 Group:          Libraries/Python
66 Requires:       python3-modules >= 1:3.3
67
68 %description -n python3-%{module}
69 This is an easy-to-use implementation of ECDSA cryptography (Elliptic
70 Curve Digital Signature Algorithm), implemented purely in Python,
71 released under the MIT license. With this library, you can quickly
72 create keypairs (signing key and verifying key), sign messages, and
73 verify the signatures. The keys and signatures are very short, making
74 them easy to handle and incorporate into other protocols.
75
76 %description -n python3-%{module} -l pl.UTF-8
77 Ten moduł to implementacja kryptografii ECDSA (Elliptic Curve Digital
78 Signature Algorytm - algorytmu podpisu cyfrowego opartego na krzywych
79 eliptycznych) w czystym Pythonie, wydana na licencji MIT. Przy użyciu
80 tej biblioteki można szybko tworzyć pary kluczy (podpisujący i
81 weryfikujący), podpisywać wiadomości oraz sprawdzać podpisy. Klucze i
82 podpisy są bardzo krótkie, co czyni je łatwymi do obsłużenia i
83 włączenia do innych protokołów.
84
85 %prep
86 %setup -q -n ecdsa-%{version}
87
88 %build
89 %if %{with python2}
90 %py_build
91
92 %if %{with tests}
93 %{__python} -m pytest src
94 %endif
95 %endif
96
97 %if %{with python3}
98 %py3_build
99
100 %if %{with tests}
101 %{__python3} -m pytest src
102 %endif
103 %endif
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 %if %{with python2}
109 %py_install
110 %endif
111
112 %if %{with python3}
113 %py3_install
114 %endif
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %if %{with python2}
120 %files
121 %defattr(644,root,root,755)
122 %doc LICENSE NEWS README.md
123 %{py_sitescriptdir}/%{module}
124 %{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
125 %endif
126
127 %if %{with python3}
128 %files -n python3-%{module}
129 %defattr(644,root,root,755)
130 %doc LICENSE NEWS README.md
131 %{py3_sitescriptdir}/%{module}
132 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
133 %endif
This page took 0.068885 seconds and 2 git commands to generate.