]> git.pld-linux.org Git - packages/python-ecdsa.git/blob - python-ecdsa.spec
- updated to 0.13.3 (fixes CVE-2019-14853)
[packages/python-ecdsa.git] / python-ecdsa.spec
1 #
2 # Conditional build:
3 %bcond_without  python2         # Python 2.x module
4 %bcond_without  python3         # Python 3.x module
5
6 %define         module  ecdsa
7 Summary:        ECDSA cryptographic signature library
8 Summary(pl.UTF-8):      Biblioteka podpisów kryptograficznych ECDSA
9 Name:           python-%{module}
10 Version:        0.13.3
11 Release:        1
12 License:        MIT
13 Group:          Development/Languages/Python
14 #Source0Download: https://pypi.org/simple/ecdsa/
15 Source0:        https://files.pythonhosted.org/packages/source/e/ecdsa/%{module}-%{version}.tar.gz
16 # Source0-md5:  b1b33f7fe171eb1278de6f93eefc34f8
17 URL:            https://pypi.org/project/ecdsa
18 BuildRequires:  rpmbuild(macros) >= 1.714
19 BuildRequires:  rpm-pythonprov
20 %if %{with python2}
21 BuildRequires:  python-devel >= 1:2.6
22 BuildRequires:  python-modules >= 1:2.6
23 BuildRequires:  python-setuptools
24 %endif
25 %if %{with python3}
26 BuildRequires:  python3-2to3 >= 1:3.2
27 BuildRequires:  python3-devel >= 1:3.2
28 BuildRequires:  python3-modules >= 1:3.2
29 BuildRequires:  python3-setuptools
30 %endif
31 Requires:       python-modules >= 1:2.6
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 This is an easy-to-use implementation of ECDSA cryptography (Elliptic
37 Curve Digital Signature Algorithm), implemented purely in Python,
38 released under the MIT license. With this library, you can quickly
39 create keypairs (signing key and verifying key), sign messages, and
40 verify the signatures. The keys and signatures are very short, making
41 them easy to handle and incorporate into other protocols.
42
43 %description -l pl.UTF-8
44 Ten moduł to implementacja kryptografii ECDSA (Elliptic Curve Digital
45 Signature Algorytm - algorytmu podpisu cyfrowego opartego na krzywych
46 eliptycznych) w czystym Pythonie, wydana na licencji MIT. Przy użyciu
47 tej biblioteki można szybko tworzyć pary kluczy (podpisujący i
48 weryfikujący), podpisywać wiadomości oraz sprawdzać podpisy. Klucze i
49 podpisy są bardzo krótkie, co czyni je łatwymi do obsłużenia i
50 włączenia do innych protokołów.
51
52 %package -n python3-%{module}
53 Summary:        ECDSA cryptographic signature library
54 Summary(pl.UTF-8):      Biblioteka podpisów kryptograficznych ECDSA
55 Group:          Libraries/Python
56 Requires:       python3-modules >= 1:3.2
57
58 %description -n python3-%{module}
59 This is an easy-to-use implementation of ECDSA cryptography (Elliptic
60 Curve Digital Signature Algorithm), implemented purely in Python,
61 released under the MIT license. With this library, you can quickly
62 create keypairs (signing key and verifying key), sign messages, and
63 verify the signatures. The keys and signatures are very short, making
64 them easy to handle and incorporate into other protocols.
65
66 %description -n python3-%{module} -l pl.UTF-8
67 Ten moduł to implementacja kryptografii ECDSA (Elliptic Curve Digital
68 Signature Algorytm - algorytmu podpisu cyfrowego opartego na krzywych
69 eliptycznych) w czystym Pythonie, wydana na licencji MIT. Przy użyciu
70 tej biblioteki można szybko tworzyć pary kluczy (podpisujący i
71 weryfikujący), podpisywać wiadomości oraz sprawdzać podpisy. Klucze i
72 podpisy są bardzo krótkie, co czyni je łatwymi do obsłużenia i
73 włączenia do innych protokołów.
74
75 %prep
76 %setup  -q -n ecdsa-%{version}
77
78 %build
79 %if %{with python2}
80 %py_build
81 %endif
82
83 %if %{with python3}
84 %py3_build
85 %endif
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89
90 %if %{with python2}
91 install -d $RPM_BUILD_ROOT%{_examplesdir}/python-%{module}-%{version}
92 %py_install
93 %endif
94
95 %if %{with python3}
96 install -d $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version}
97 %py3_install
98 %endif
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %if %{with python2}
104 %files
105 %defattr(644,root,root,755)
106 %doc LICENSE NEWS README.md
107 %{py_sitescriptdir}/%{module}
108 %{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
109 %{_examplesdir}/python-%{module}-%{version}
110 %endif
111
112 %if %{with python3}
113 %files -n python3-%{module}
114 %defattr(644,root,root,755)
115 %doc LICENSE NEWS README.md
116 %{py3_sitescriptdir}/%{module}
117 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
118 %{_examplesdir}/python3-%{module}-%{version}
119 %endif
This page took 0.062182 seconds and 3 git commands to generate.