]> git.pld-linux.org Git - packages/python-dotenv.git/blob - python-dotenv.spec
rebuild with tests and docs
[packages/python-dotenv.git] / python-dotenv.spec
1 # Conditional build:
2 %bcond_without  python2 # CPython 2.x module
3 %bcond_without  python3 # CPython 3.x module
4
5 %define         module          dotenv
6 %define         pypi_name       python-dotenv
7 %define         egg_name        python_dotenv
8 Summary:        Add .env support to your django/flask apps in development and deployments
9 Name:           python-%{module}
10 Version:        0.17.0
11 Release:        5
12 License:        BSD
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.org/simple/python-dotenv/
15 Source0:        https://files.pythonhosted.org/packages/source/p/python-dotenv/%{pypi_name}-%{version}.tar.gz
16 # Source0-md5:  664e1fd991a2dd109c95b743bb9eecd5
17 URL:            https://pypi.org/project/python-dotenv/
18 %if %{with python2}
19 BuildRequires:  python-modules >= 1:2.5
20 BuildRequires:  python-setuptools
21 %endif
22 %if %{with python3}
23 BuildRequires:  python3-modules >= 1:3.2
24 BuildRequires:  python3-setuptools
25 %endif
26 BuildRequires:  rpm-pythonprov
27 BuildRequires:  rpmbuild(macros) >= 1.714
28 Requires:       python-modules >= 1:2.5
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Add .env support to your django/flask apps in development and
34 deployments.
35
36 %package -n python3-%{module}
37 Summary:        -
38 Summary(pl.UTF-8):      -
39 Group:          Libraries/Python
40 Requires:       python3-modules >= 1:3.2
41
42 %description -n python3-%{module}
43 Add .env support to your django/flask apps in development and
44 deployments.
45
46 %prep
47 %setup -q -n %{pypi_name}-%{version}
48
49 %build
50 %if %{with python2}
51 %py_build
52 %endif
53
54 %if %{with python3}
55 %py3_build
56 %endif
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %if %{with python2}
62 %py_install
63
64 %py_postclean
65 %endif
66
67 %if %{with python3}
68 %py3_install
69 %endif
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %if %{with python2}
75 %files
76 %defattr(644,root,root,755)
77 %doc CHANGELOG.md CONTRIBUTING.md README.md
78 %{py_sitescriptdir}/%{module}
79 %{py_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
80 %endif
81
82 %if %{with python3}
83 %files -n python3-%{module}
84 %defattr(644,root,root,755)
85 %doc CHANGELOG.md CONTRIBUTING.md README.md
86 %{py3_sitescriptdir}/%{module}
87 %{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
88 %endif
This page took 0.091066 seconds and 3 git commands to generate.