]> git.pld-linux.org Git - packages/python-doctest-ignore-unicode.git/blob - python-doctest-ignore-unicode.spec
- new
[packages/python-doctest-ignore-unicode.git] / python-doctest-ignore-unicode.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 Summary:        Add flag to ignore unicode literal prefixes in doctests
7 Summary(pl.UTF-8):      Flaga do ignorowania prefiksów stałych unikodowych w doctestach
8 Name:           python-doctest-ignore-unicode
9 Version:        0.1.2
10 Release:        1
11 License:        Apache v2.0
12 Group:          Libraries/Python
13 #Source0Download: https://pypi.org/simple/doctest-ignore-unicode/
14 Source0:        https://files.pythonhosted.org/packages/source/d/doctest-ignore-unicode/doctest-ignore-unicode-%{version}.tar.gz
15 # Source0-md5:  ba64fe1ef48e8ed68d9ac9a9a03d0c65
16 URL:            https://pypi.org/project/doctest-ignore-unicode/
17 %if %{with python2}
18 BuildRequires:  python-modules >= 1:2.5
19 BuildRequires:  python-setuptools
20 %endif
21 %if %{with python3}
22 BuildRequires:  python3-modules >= 1:3.2
23 BuildRequires:  python3-setuptools
24 %endif
25 BuildRequires:  rpm-pythonprov
26 BuildRequires:  rpmbuild(macros) >= 1.714
27 Requires:       python-modules >= 1:2.5
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 doctest-ignore-unicode is a plugin (currently only for Nose) that adds
33 a flag to ignore unicode literal prefixes in doctests.
34
35 %description -l pl.UTF-8
36 doctest-ignore-unicode to wtyczka (obecnie tylko dla Nose), dodająca
37 flagę do ignorowania prefiksów stałych unikodowych w doctestach.
38
39 %package -n python3-doctest-ignore-unicode
40 Summary:        Add flag to ignore unicode literal prefixes in doctests
41 Summary(pl.UTF-8):      Flaga do ignorowania prefiksów stałych unikodowych w doctestach
42 Group:          Libraries/Python
43 Requires:       python3-modules >= 1:3.2
44
45 %description -n python3-doctest-ignore-unicode
46 doctest-ignore-unicode is a plugin (currently only for Nose) that adds
47 a flag to ignore unicode literal prefixes in doctests.
48
49 %description -n python3-doctest-ignore-unicode -l pl.UTF-8
50 doctest-ignore-unicode to wtyczka (obecnie tylko dla Nose), dodająca
51 flagę do ignorowania prefiksów stałych unikodowych w doctestach.
52
53 %prep
54 %setup -q -n doctest-ignore-unicode-%{version}
55
56 %build
57 %if %{with python2}
58 %py_build
59 %endif
60
61 %if %{with python3}
62 %py3_build
63 %endif
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 %if %{with python2}
69 %py_install
70
71 %py_postclean
72 %endif
73
74 %if %{with python3}
75 %py3_install
76 %endif
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %if %{with python2}
82 %files
83 %defattr(644,root,root,755)
84 %doc README.rst
85 %{py_sitescriptdir}/nose_plugin.py[co]
86 %{py_sitescriptdir}/doctest_ignore_unicode-%{version}-py*.egg-info
87 %endif
88
89 %if %{with python3}
90 %files -n python3-doctest-ignore-unicode
91 %defattr(644,root,root,755)
92 %doc README.rst
93 %{py3_sitescriptdir}/nose_plugin.py
94 %{py3_sitescriptdir}/__pycache__/nose_plugin.cpython-*.py[co]
95 %{py3_sitescriptdir}/doctest_ignore_unicode-%{version}-py*.egg-info
96 %endif
This page took 0.052119 seconds and 3 git commands to generate.