]> git.pld-linux.org Git - packages/python-docrepr.git/blob - python-docrepr.spec
rebuild with tests and docs
[packages/python-docrepr.git] / python-docrepr.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 Summary:        Rendering Python docstrings in HTML
7 Summary(pl.UTF-8):      Obrazowanie pythonowych docstringów w HTML-u
8 Name:           python-docrepr
9 Version:        0.1.1
10 Release:        6
11 License:        BSD
12 Group:          Libraries/Python
13 #Source0Download: https://pypi.org/simple/docrepr/
14 Source0:        https://files.pythonhosted.org/packages/source/d/docrepr/docrepr-%{version}.tar.gz
15 # Source0-md5:  e2d1b964a9f63518dcbd1d31b7273104
16 URL:            https://pypi.org/project/docrepr/
17 %if %{with python2}
18 BuildRequires:  python-modules >= 1:2.5
19 BuildRequires:  python-setuptools
20 %endif
21 %if %{with python3}
22 BuildRequires:  python3-modules >= 1:3.2
23 BuildRequires:  python3-setuptools
24 %endif
25 BuildRequires:  rpm-pythonprov
26 BuildRequires:  rpmbuild(macros) >= 1.714
27 Requires:       python-modules >= 1:2.5
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 docrepr renders Python docstrings in HTML. It is based on the
33 sphinxify module developed by Tim Dumol for the Sage Notebook and the
34 utils.inspector developed for their Spyder IDE.
35
36 %description -l pl.UTF-8
37 docrepr obrazuje pythonowe docstringi w HTML-u. Jest oparty na module
38 sphinxify, stworzonym przez Tima Dumola dla Sage Nootebooka oraz
39 utils.inspector, powstałego dla ich Spyder IDE.
40
41 %package -n python3-docrepr
42 Summary:        Rendering Python docstrings in HTML
43 Summary(pl.UTF-8):      Obrazowanie pythonowych docstringów w HTML-u
44 Group:          Libraries/Python
45 Requires:       python3-modules >= 1:3.2
46
47 %description -n python3-docrepr
48 docrepr renders Python docstrings in HTML. It is based on the
49 sphinxify module developed by Tim Dumol for the Sage Notebook and the
50 utils.inspector developed for their Spyder IDE.
51
52 %description -n python3-docrepr -l pl.UTF-8
53 docrepr obrazuje pythonowe docstringi w HTML-u. Jest oparty na module
54 sphinxify, stworzonym przez Tima Dumola dla Sage Nootebooka oraz
55 utils.inspector, powstałego dla ich Spyder IDE.
56
57 %prep
58 %setup -q -n docrepr-%{version}
59
60 %build
61 %if %{with python2}
62 %py_build
63 %endif
64
65 %if %{with python3}
66 %py3_build
67 %endif
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %if %{with python2}
73 %py_install
74
75 %py_postclean
76 %endif
77
78 %if %{with python3}
79 %py3_install
80 %endif
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %if %{with python2}
86 %files
87 %defattr(644,root,root,755)
88 %doc README.md
89 %{py_sitescriptdir}/docrepr
90 %{py_sitescriptdir}/docrepr-%{version}-py*.egg-info
91 %endif
92
93 %if %{with python3}
94 %files -n python3-docrepr
95 %defattr(644,root,root,755)
96 %doc README.md
97 %{py3_sitescriptdir}/docrepr
98 %{py3_sitescriptdir}/docrepr-%{version}-py*.egg-info
99 %endif
This page took 0.089709 seconds and 3 git commands to generate.