]> git.pld-linux.org Git - packages/python-dns.git/blob - python-dns.spec
- release 3 (by relup.sh)
[packages/python-dns.git] / python-dns.spec
1 # NOTE: python3 version in separate package (python3-dns)
2
3 %define         module  dns
4
5 Summary:        dnspython - a DNS toolkit for Python
6 Summary(pl.UTF-8):      dnspython - zestaw narzędzi do DNS dla Pythona
7 Name:           python-%{module}
8 Version:        1.11.1
9 Release:        3
10 License:        MIT
11 Group:          Development/Languages/Python
12 Source0:        http://www.dnspython.org/kits/%{version}/dnspython-%{version}.tar.gz
13 # Source0-md5:  6167344ca849bd2ba108a8aa6118cb2b
14 URL:            http://www.dnspython.org/
15 BuildRequires:  python-devel >= 1:2.5
16 BuildRequires:  rpm-pythonprov
17 BuildRequires:  rpmbuild(macros) >= 1.710
18 %pyrequires_eq  python-modules
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 dnspython is a DNS toolkit for Python. It supports almost all record
24 types. It can be used for queries, zone transfers, and dynamic
25 updates. It supports TSIG authenticated messages and EDNS0.
26
27 dnspython provides both high and low level access to DNS. The high
28 level classes perform queries for data of a given name, type, and
29 class, and return an answer set. The low level classes allow direct
30 manipulation of DNS zones, messages, names, and records.
31
32 %description -l pl.UTF-8
33 dnspython to zestaw narzędzi do DNS dla Pythona. Obsługuje prawie
34 wszystkie rodzaje rekordów. Może być używany do zapytań, transferów
35 stref oraz dynamicznych uaktualnień. Obsługuje uwierzytelnione
36 komunikaty TSIG oraz EDNS0.
37
38 dnspython dostarcza zarówno wysoko- jak i niskopoziomowy dostęp do
39 DNS-a. Klasy wysokopoziomowe wykonują zapytania o dane dla podanej
40 nazwy, rodzaju i klasy, a zwracają zbiór odpowiedzi. Klasy
41 niskopoziomowe umożliwiają bezpośrednie manipulacje na strefach,
42 komunikatach, nazwach i rekordach w DNS-ie.
43
44 %prep
45 %setup -q -n dnspython-%{version}
46
47 %build
48 %py_build
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
53
54 cp -r examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
55
56 %py_install
57
58 %py_postclean
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc ChangeLog LICENSE README
66 %{py_sitescriptdir}/%{module}
67 %{py_sitescriptdir}/*.egg-info
68 %{_examplesdir}/%{name}-%{version}
This page took 0.084566 seconds and 3 git commands to generate.