]> git.pld-linux.org Git - packages/python-django_profile.git/blob - python-django_profile.spec
- new
[packages/python-django_profile.git] / python-django_profile.spec
1 %define         module          profile
2 %define         svnrev          r420
3 Summary:        Django pluggable user profile zone
4 Name:           python-django_profile
5 Version:        0.6
6 Release:        1.%{svnrev}.0.1
7 License:        MIT
8 Group:          Development/Languages/Python
9 #Source0:       http://django-profile.googlecode.com/files/django-%{module}-%{version}.tgz
10 Source0:        django-profile-%{svnrev}.tgz
11 # Source0-md5:  c0d3893085535bed3389674c550436a5
12 URL:            http://code.google.com/p/django-profile/
13 BuildRequires:  python-devel
14 BuildRequires:  rpm-pythonprov
15 BuildRequires:  rpmbuild(macros) >= 1.219
16 %pyrequires_eq  python-modules
17 Requires:       python-django >= 1.0
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 This is a Django pluggable user profile zone which can be used and
23 customized easily in your social application web platform developed in
24 django.
25
26 It's developed with Django for the backend framework and uses Jquery
27 as the javascript library for the client UI. It avoids big amounts of
28 development time process in such a generic thing as the User Profile
29 and account utilities.
30
31 %prep
32 %setup -q -n django-profile
33
34 %build
35 export CFLAGS="%{rpmcflags}"
36 %{__python} setup.py build
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 %{__python} setup.py install \
41         --optimize=2 \
42         --root=$RPM_BUILD_ROOT
43
44 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
45 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
46 %py_postclean
47
48 rm -rf $RPM_BUILD_ROOT%{py_sitescriptdir}/demo
49 rm -rf $RPM_BUILD_ROOT%{py_sitescriptdir}/userprofile-0.6-py2.6.egg-info
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %{py_sitescriptdir}/userprofile
This page took 0.111873 seconds and 4 git commands to generate.