]> git.pld-linux.org Git - packages/python-django_profile.git/blob - python-django_profile.spec
automatic change: use py_build/py_install macros
[packages/python-django_profile.git] / python-django_profile.spec
1 %define         module          profile
2 %define         svnrev          r420
3 Summary:        Django pluggable user profile zone
4 Name:           python-django_profile
5 Version:        0.6
6 Release:        1.%{svnrev}.0.1
7 License:        MIT
8 Group:          Development/Languages/Python
9 #Source0:       http://django-profile.googlecode.com/files/django-%{module}-%{version}.tgz
10 Source0:        django-profile-%{svnrev}.tgz
11 # Source0-md5:  c0d3893085535bed3389674c550436a5
12 URL:            http://code.google.com/p/django-profile/
13 BuildRequires:  python-devel
14 BuildRequires:  rpm-pythonprov
15 BuildRequires:  rpmbuild(macros) >= 1.219
16 %pyrequires_eq  python-modules
17 Requires:       python-django >= 1.0
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 This is a Django pluggable user profile zone which can be used and
23 customized easily in your social application web platform developed in
24 django.
25
26 It's developed with Django for the backend framework and uses Jquery
27 as the javascript library for the client UI. It avoids big amounts of
28 development time process in such a generic thing as the User Profile
29 and account utilities.
30
31 %prep
32 %setup -q -n django-profile
33
34 %build
35 %py_build
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 %py_install
40
41 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
42 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
43 %py_postclean
44
45 rm -rf $RPM_BUILD_ROOT%{py_sitescriptdir}/demo
46 rm -rf $RPM_BUILD_ROOT%{py_sitescriptdir}/userprofile-0.6-py2.6.egg-info
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %{py_sitescriptdir}/userprofile
This page took 0.056911 seconds and 4 git commands to generate.