]> git.pld-linux.org Git - packages/python-django-voting.git/blob - python-django-voting.spec
486921c22901545a452a03e53c235546b769e87b
[packages/python-django-voting.git] / python-django-voting.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         module  django-voting
6 Summary:        Generic voting application for Django
7 Name:           python-%{module}
8 Version:        0.2
9 Release:        2
10 License:        BSD
11 Group:          Libraries/Python
12 Source0:        https://pypi.python.org/packages/source/d/django-voting/django-voting-%{version}.tar.gz
13 # Source0-md5:  d4dbc8c0530f127027f6af6e76f91ead
14 URL:            https://pypi.python.org/pypi/django-voting
15 BuildRequires:  rpm-pythonprov
16 BuildRequires:  rpmbuild(macros) >= 1.710
17 Requires:       python-modules
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 This is a generic voting application for Django projects.
23
24 %prep
25 %setup -q -n %{module}-%{version}
26
27 %build
28 %py_build
29
30 %install
31 rm -rf $RPM_BUILD_ROOT
32 %py_install
33
34 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/voting/tests
35
36 %py_postclean
37
38 %clean
39 rm -rf $RPM_BUILD_ROOT
40
41 %files
42 %defattr(644,root,root,755)
43 %doc CHANGELOG.txt INSTALL.txt LICENSE.txt README.txt docs/overview.txt
44 %dir %{py_sitescriptdir}/voting
45 %{py_sitescriptdir}/voting/*.py[co]
46 %{py_sitescriptdir}/voting/migrations
47 %{py_sitescriptdir}/voting/templatetags
48 %{py_sitescriptdir}/django_voting-%{version}-py*.egg-info
This page took 0.07398 seconds and 2 git commands to generate.