]> git.pld-linux.org Git - packages/python-django-pipeline.git/blob - python-django-pipeline.spec
up to 1.2.24
[packages/python-django-pipeline.git] / python-django-pipeline.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 Summary:        An asset packaging library for Django
6 Name:           python-django-pipeline
7 Version:        1.2.24
8 Release:        1
9 License:        MIT
10 Group:          Applications/Networking
11 URL:            https://github.com/cyberdelia/django-pipeline
12 Source0:        http://pypi.python.org/packages/source/d/django-pipeline/django-pipeline-%{version}.tar.gz
13 # Source0-md5:  972d1be867a61680b67e09a6ec55d839
14 BuildRequires:  python-devel
15 BuildRequires:  python-setuptools
16 BuildRequires:  rpm-pythonprov
17 BuildRequires:  rpmbuild(macros) >= 1.219
18 Requires:       python-django
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Pipeline is an asset packaging library for Django, providing both CSS
24 and JavaScript concatenation and compression, built-in JavaScript
25 template support, and optional data-URI image and font embedding
26
27 %prep
28 %setup -q -n django-pipeline-%{version}
29 %{__rm} -r django_pipeline*.egg-info
30
31 %build
32 %{__python} setup.py build
33
34 %{?with_tests:%{__python} setup.py test}
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 %{__python} setup.py install \
39         --skip-build \
40         --optimize=2 \
41         --root $RPM_BUILD_ROOT
42
43 %py_postclean
44
45 # Remove the "tests" subdirectory to avoid it polluting the main python namespace:
46 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/tests
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc LICENSE AUTHORS HISTORY.rst README.rst
54 %dir %{py_sitescriptdir}/pipeline
55 %dir %{py_sitescriptdir}/pipeline/compilers
56 %dir %{py_sitescriptdir}/pipeline/compressors
57 %dir %{py_sitescriptdir}/pipeline/conf
58 %dir %{py_sitescriptdir}/pipeline/jinja2
59 %dir %{py_sitescriptdir}/pipeline/templatetags
60 %{py_sitescriptdir}/pipeline/*.py[co]
61 %{py_sitescriptdir}/pipeline/compilers/*.py[co]
62 %{py_sitescriptdir}/pipeline/compressors/*.py[co]
63 %{py_sitescriptdir}/pipeline/conf/*.py[co]
64 %{py_sitescriptdir}/pipeline/jinja2/*.py[co]
65 %{py_sitescriptdir}/pipeline/templates
66 %{py_sitescriptdir}/pipeline/templatetags/*.py[co]
67 %{py_sitescriptdir}/django_pipeline*.egg-info
68
This page took 0.084519 seconds and 3 git commands to generate.