]> git.pld-linux.org Git - packages/python-decorator.git/blob - python-decorator.spec
- pl, unified
[packages/python-decorator.git] / python-decorator.spec
1 %define module decorator
2 Summary:        Bunch of nice decorators for Python
3 Summary(pl.UTF-8):      Zbiór ładnych dekoratorów dla Pythona
4 Name:           python-%{module}
5 Version:        2.2.0
6 Release:        1
7 License:        BSD
8 Group:          Python/Libraries
9 Source0:        http://www.phyast.pitt.edu/~micheles/python/%{module}-%{version}.zip
10 # Source0-md5:  4732d42d7b9f1b19de960a84b57a63da
11 URL:            http://www.phyast.pitt.edu/~micheles/python/documentation.html
12 BuildRequires:  python-devel
13 %pyrequires_eq  python-libs
14 Requires:       python-pygtk-gtk >= 2.8.4
15 BuildArch:      noarch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Bunch of nice decorators for Python like memoize, tracing,
20 redirecting_stdout, locked.
21
22 %description -l pl.UTF-8
23 Zbiór ładnych dekoratorów dla Pythona: memoize, tracing,
24 redirecting_stdout, locked...
25
26 %prep
27 %setup -qc
28
29 %build
30 %{__python} setup.py build
31
32 %install
33 rm -rf $RPM_BUILD_ROOT
34
35 %{__python} setup.py install \
36         --optimize=2 \
37         --root=$RPM_BUILD_ROOT
38
39 %py_postclean
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %files
45 %defattr(644,root,root,755)
46 %doc documentation.* README.txt
47 %{py_sitescriptdir}/decorator*
This page took 0.112202 seconds and 4 git commands to generate.