]> git.pld-linux.org Git - packages/python-decorator.git/blob - python-decorator.spec
- updated to 4.0.9
[packages/python-decorator.git] / python-decorator.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 %define         module decorator
7 Summary:        Bunch of nice decorators for Python 2
8 Summary(pl.UTF-8):      Zbiór ładnych dekoratorów dla Pythona 2
9 Name:           python-%{module}
10 Version:        4.0.9
11 Release:        1
12 License:        BSD
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.python.org/simple/decorator/
15 Source0:        https://pypi.python.org/packages/source/d/decorator/%{module}-%{version}.tar.gz
16 # Source0-md5:  f12c5651ccd707e12a0abaa4f76cd69a
17 URL:            https://pypi.python.org/pypi/decorator/
18 %if %{with python2}
19 BuildRequires:  python-devel >= 1:2.4
20 BuildRequires:  python-modules >= 1:2.4
21 BuildRequires:  python-setuptools
22 %endif
23 %if %{with python3}
24 BuildRequires:  python3-devel >= 1:3.2
25 BuildRequires:  python3-modules >= 1:3.2
26 BuildRequires:  python3-setuptools
27 %endif
28 BuildRequires:  rpm-pythonprov
29 BuildRequires:  rpmbuild(macros) >= 1.710
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Bunch of nice decorators for Python 2 like memoize, tracing,
35 redirecting_stdout, locked.
36
37 %description -l pl.UTF-8
38 Zbiór ładnych dekoratorów dla Pythona 2: memoize, tracing,
39 redirecting_stdout, locked...
40
41 %package -n python3-%{module}
42 Summary:        Bunch of nice decorators for Python 3
43 Summary(pl.UTF-8):      Zbiór ładnych dekoratorów dla Pythona 3
44 Group:          Libraries/Python
45
46 %description -n python3-%{module}
47 Bunch of nice decorators for Python 3 like memoize, tracing,
48 redirecting_stdout, locked.
49
50 %description -n python3-%{module} -l pl.UTF-8
51 Zbiór ładnych dekoratorów dla Pythona 3: memoize, tracing,
52 redirecting_stdout, locked...
53
54 %package doc
55 Summary:        Documentation for decorator module in PDF format
56 Summary(pl.UTF-8):      Dokumentacja modułu decorator w formacie PDF
57 Group:          Documentation
58
59 %description doc
60 Documentation for decorator module in PDF format.
61
62 %description doc -l pl.UTF-8
63 Dokumentacja modułu decorator w formacie PDF.
64
65 %prep
66 %setup -q -n %{module}-%{version}
67
68 %build
69 %if %{with python2}
70 %py_build
71 %endif
72 %if %{with python3}
73 %py3_build
74 %endif
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78
79 %if %{with python2}
80 %py_install
81
82 %py_postclean
83 %endif
84
85 %if %{with python3}
86 %py3_install
87 %endif
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %if %{with python2}
93 %files
94 %defattr(644,root,root,755)
95 %doc CHANGES.md LICENSE.txt docs/README.rst
96 %{py_sitescriptdir}/decorator.py[co]
97 %{py_sitescriptdir}/decorator-%{version}-py*.egg-info
98 %endif
99
100 %if %{with python3}
101 %files -n python3-%{module}
102 %defattr(644,root,root,755)
103 %doc CHANGES.md LICENSE.txt docs/README.rst
104 %{py3_sitescriptdir}/decorator.py
105 %{py3_sitescriptdir}/__pycache__/decorator.*.py[co]
106 %{py3_sitescriptdir}/decorator-%{version}-py*.egg-info
107 %endif
108
109 %files doc
110 %defattr(644,root,root,755)
111 %doc documentation.pdf
This page took 0.036376 seconds and 4 git commands to generate.