]> git.pld-linux.org Git - packages/python3-cloudpickle.git/blob - python-cloudpickle.spec
- new
[packages/python3-cloudpickle.git] / python-cloudpickle.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # unit tests (some incompatible with python2, few failing on python3.8)
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 Summary:        Extended pickling support for Python objects
8 Summary(pl.UTF-8):      Rozszerzona obsługa operacji pickle dla obiektów pythonowych
9 Name:           python-cloudpickle
10 # keep 1.3.x here for python2 support
11 Version:        1.3.0
12 Release:        1
13 License:        BSD
14 Group:          Libraries/Python
15 #Source0Download: https://pypi.org/simple/cloudpickle/
16 Source0:        https://files.pythonhosted.org/packages/source/c/cloudpickle/cloudpickle-%{version}.tar.gz
17 # Source0-md5:  625d9c80e1b4f2a3dea01f1b4c149511
18 URL:            https://pypi.org/project/cloudpickle/
19 %if %{with python2}
20 BuildRequires:  python-modules >= 1:2.7
21 BuildRequires:  python-setuptools
22 %if %{with tests}
23 BuildRequires:  python-numpy
24 BuildRequires:  python-pytest
25 BuildRequires:  python-scipy
26 %endif
27 %endif
28 %if %{with python3}
29 BuildRequires:  python3-modules >= 1:3.5
30 BuildRequires:  python3-setuptools
31 %if %{with tests}
32 BuildRequires:  python3-numpy
33 BuildRequires:  python3-pytest
34 BuildRequires:  python3-scipy
35 %endif
36 %endif
37 BuildRequires:  rpm-pythonprov
38 BuildRequires:  rpmbuild(macros) >= 1.714
39 Requires:       python-modules >= 1:2.7
40 BuildArch:      noarch
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 cloudpickle makes it possible to serialize Python constructs not
45 supported by the default pickle module from the Python standard
46 library.
47
48 cloudpickle is especially useful for cluster computing where Python
49 code is shipped over the network to execute on remote hosts, possibly
50 close to the data.
51
52 Among other things, cloudpickle supports pickling for lambda functions
53 along with functions and classes defined interactively in the __main__
54 module (for instance in a script, a shell or a Jupyter notebook).
55
56 %description -l pl.UTF-8
57 cloudpickle pozwala serializować konstrukcje pythonowe nie obsługiwane
58 domyślnie przez moduł pickle z biblioteki standardowej Pythona.
59
60 cloudpickle jest przydatne szczególnie przy obliczeniach klastrowych,
61 gdzie kod pythonowy jest rozmieszczony po sieci, aby wykonywał się na
62 zdalnych maszynach, możliwie blisko danych.
63
64 cloudpickle obsługuje m.in. operacje pickle na funkcjach lambda oraz
65 funkcjach lub klasach definiowanych interaktywnie w module __main__
66 (np. w skrypcie, z powłoki lub w postaci Jupyter notebook).
67
68 %package -n python3-cloudpickle
69 Summary:        Extended pickling support for Python objects
70 Summary(pl.UTF-8):      Rozszerzona obsługa operacji pickle dla obiektów pythonowych
71 Group:          Libraries/Python
72 Requires:       python3-modules >= 1:3.5
73
74 %description -n python3-cloudpickle
75 cloudpickle makes it possible to serialize Python constructs not
76 supported by the default pickle module from the Python standard
77 library.
78
79 cloudpickle is especially useful for cluster computing where Python
80 code is shipped over the network to execute on remote hosts, possibly
81 close to the data.
82
83 Among other things, cloudpickle supports pickling for lambda functions
84 along with functions and classes defined interactively in the __main__
85 module (for instance in a script, a shell or a Jupyter notebook).
86
87 %description -n python3-cloudpickle -l pl.UTF-8
88 cloudpickle pozwala serializować konstrukcje pythonowe nie obsługiwane
89 domyślnie przez moduł pickle z biblioteki standardowej Pythona.
90
91 cloudpickle jest przydatne szczególnie przy obliczeniach klastrowych,
92 gdzie kod pythonowy jest rozmieszczony po sieci, aby wykonywał się na
93 zdalnych maszynach, możliwie blisko danych.
94
95 cloudpickle obsługuje m.in. operacje pickle na funkcjach lambda oraz
96 funkcjach lub klasach definiowanych interaktywnie w module __main__
97 (np. w skrypcie, z powłoki lub w postaci Jupyter notebook).
98
99 %prep
100 %setup -q -n cloudpickle-%{version}
101
102 %build
103 %if %{with python2}
104 %py_build %{?with_tests:test}
105 %endif
106
107 %if %{with python3}
108 %py3_build %{?with_tests:test}
109 %endif
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113
114 %if %{with python2}
115 %py_install
116
117 %py_postclean
118 %endif
119
120 %if %{with python3}
121 %py3_install
122 %endif
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %if %{with python2}
128 %files
129 %defattr(644,root,root,755)
130 %doc LICENSE README.md
131 %{py_sitescriptdir}/cloudpickle
132 %{py_sitescriptdir}/cloudpickle-%{version}-py*.egg-info
133 %endif
134
135 %if %{with python3}
136 %files -n python3-cloudpickle
137 %defattr(644,root,root,755)
138 %doc LICENSE README.md
139 %{py3_sitescriptdir}/cloudpickle
140 %{py3_sitescriptdir}/cloudpickle-%{version}-py*.egg-info
141 %endif
This page took 0.057349 seconds and 3 git commands to generate.