]> git.pld-linux.org Git - packages/python-cfgparse.git/blob - python-cfgparse.spec
55480b44e4851d2489ea88a96eab7efca2c8cc63
[packages/python-cfgparse.git] / python-cfgparse.spec
1 #
2 %define         module  cfgparse
3 %define         _ver    v01_02
4 %define         ver     %(echo %{_ver} | sed -e 's@^v0@@' -e 's@_@.@g')
5 #
6 Summary:        Python configuration file parser module
7 Summary(pl.UTF-8):      Moduł Pythona do parsowania plików konfiguracyjnych
8 Name:           python-cfgparse
9 Version:        %{ver}
10 Release:        3
11 License:        distrubutable   
12 Group:          Libraries/Python
13 Source0:        http://dl.sourceforge.net/cfgparse/%{module}-%{_ver}.tar.gz
14 # Source0-md5:  9add1b0bbf828f7c7383407cdeefea94
15 URL:            http://cfgparse.sourceforge.net/
16 BuildRequires:  python >= 2.3
17 BuildRequires:  python-modules
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.231
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Python configuration file parser module.
25
26 %description -l pl.UTF-8
27 Moduł Pythona do parsowania plików konfiguracyjnych.
28
29 %prep
30 %setup -q -n %{module}-%{_ver}
31
32 %install
33 rm -rf $RPM_BUILD_ROOT
34
35 python ./setup.py install \
36         --root=$RPM_BUILD_ROOT
37
38 # make python *.pyo files
39 %{py_ocomp} $RPM_BUILD_ROOT%{py_sitescriptdir}
40
41 # remove .py files, leave just compiled ones.
42 %{py_postclean}
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 %defattr(644,root,root,755)
49 %doc README.txt docs/cfgparse.pdf docs/cfgparse/* 
50 %{py_sitescriptdir}/*.py[co]
This page took 0.095281 seconds and 2 git commands to generate.