]> git.pld-linux.org Git - packages/python-cffi.git/blob - python-cffi.spec
72d976c29173b30b5fea47b3dd112d804c947f43
[packages/python-cffi.git] / python-cffi.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5 %bcond_without  doc     # sphinx based documentation
6 #
7 Summary:        Foreign Function Interface for Python 2 calling C code
8 Summary(pl.UTF-8):      Interfejs funkcji obcych (FFI) dla Pythona 2 wywołującego kod w C
9 Name:           python-cffi
10 Version:        1.2.1
11 Release:        3
12 License:        MIT
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.python.org/pypi/cffi
15 Source0:        https://pypi.python.org/packages/source/c/cffi/cffi-%{version}.tar.gz
16 # Source0-md5:  faca1e420e80433db409bb1bdd0a3f45
17 URL:            http://cffi.readthedocs.org/
18 BuildRequires:  libffi-devel >= 3
19 BuildRequires:  pkgconfig
20 %if %{with python2}
21 BuildRequires:  python >= 1:2.6
22 BuildRequires:  python-devel >= 1:2.6
23 %endif
24 %if %{with python3}
25 BuildRequires:  python3 >= 1:3.2
26 BuildRequires:  python3-devel >= 1:3.2
27 %endif
28 BuildRequires:  rpm-pythonprov
29 BuildRequires:  rpmbuild(macros) >= 1.710
30 %{?with_doc:BuildRequires:      sphinx-pdg}
31 Requires:       python-modules
32 Requires:       python-pycparser
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Foreign Function Interface for Python calling C code. The aim of this
37 project is to provide a convenient and reliable way of calling C code
38 from Python without learning additional language or API.
39
40 This package contains Python 2 module.
41
42 %description -l pl.UTF-8
43 CFFI to interfejs funkcji obcych (FFI - foreign Function Interface) do
44 wywoływania kodu w C z Pythona. Celem projektu jest dostarczenie
45 wygodnego i wiarygodnego sposobu wywoływania kodu w C z Pythona bez
46 potrzeby nauki dodatkowego języka lub API.
47
48 Ten pakiet zawiera moduł Pythona 2.
49
50 %package -n python3-cffi
51 Summary:        Foreign Function Interface for Python 3 calling C code
52 Summary(pl.UTF-8):      Interfejs funkcji obcych (FFI) dla Pythona 3 wywołującego kod w C
53 Group:          Libraries/Python
54 Requires:       python3-modules
55 Requires:       python3-pycparser
56
57 %description -n python3-cffi
58 Foreign Function Interface for Python calling C code. The aim of this
59 project is to provide a convenient and reliable way of calling C code
60 from Python without learning additional language or API.
61
62 This package contains Python 3 module.
63
64 %description -n python3-cffi -l pl.UTF-8
65 CFFI to interfejs funkcji obcych (FFI - foreign Function Interface) do
66 wywoływania kodu w C z Pythona. Celem projektu jest dostarczenie
67 wygodnego i wiarygodnego sposobu wywoływania kodu w C z Pythona bez
68 potrzeby nauki dodatkowego języka lub API.
69
70 Ten pakiet zawiera moduł Pythona 3.
71
72 %prep
73 %setup -q -n cffi-%{version}
74
75 %build
76 %if %{with python2}
77 %py_build \
78         --build-base build-2
79 %endif
80 %if %{with python3}
81 %py3_build \
82         --build-base build-3
83 %endif
84
85 %if %{with doc}
86 %{__make} -C doc html
87 %endif
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91
92 %if %{with python2}
93 %{__python} setup.py \
94         build \
95                 --build-base build-2 \
96         install \
97                 --root=$RPM_BUILD_ROOT \
98                 --optimize=2
99
100 %py_postclean
101 %endif
102
103 %if %{with python3}
104 %{__python3} setup.py \
105         build \
106                 --build-base build-3 \
107         install \
108                 --root=$RPM_BUILD_ROOT \
109                 --optimize=2
110 %endif
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %if %{with python2}
116 %files
117 %defattr(644,root,root,755)
118 %doc LICENSE %{?with_doc:doc/build/html/{*.html,*.js,_static}}
119 %attr(755,root,root) %{py_sitedir}/_cffi_backend.so
120 %dir %{py_sitedir}/cffi
121 %{py_sitedir}/cffi/_cffi_include.h
122 %{py_sitedir}/cffi/parse_c_type.h
123 %{py_sitedir}/cffi/*.py[co]
124 %{py_sitedir}/cffi-%{version}-py*.egg-info
125 %endif
126
127 %if %{with python3}
128 %files -n python3-cffi
129 %defattr(644,root,root,755)
130 %doc LICENSE %{?with_doc:doc/build/html/{*.html,*.js,_static}}
131 %attr(755,root,root) %{py3_sitedir}/_cffi_backend.cpython-*.so
132 %dir %{py3_sitedir}/cffi
133 %{py3_sitedir}/cffi/_cffi_include.h
134 %{py3_sitedir}/cffi/parse_c_type.h
135 %{py3_sitedir}/cffi/*.py
136 %{py3_sitedir}/cffi/__pycache__
137 %{py3_sitedir}/cffi-%{version}-py*.egg-info
138 %endif
This page took 0.025355 seconds and 2 git commands to generate.