]> git.pld-linux.org Git - packages/python-casttube.git/blob - python-casttube.spec
6fb09337f999de5fd5a627f85f0e8d51f9384065
[packages/python-casttube.git] / python-casttube.spec
1 # Conditional build:
2 %bcond_without  tests   # unit tests
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 %define         module          casttube
7 %define         egg_name        casttube
8 %define         pypi_name       casttube
9 Summary:        casttube provides a way to interact with the Youtube Chromecast api
10 Name:           python-%{module}
11 Version:        0.2.0
12 Release:        5
13 License:        MIT
14 Group:          Libraries/Python
15 Source0:        https://pypi.debian.net/casttube/%{pypi_name}-%{version}.tar.gz
16 # Source0-md5:  4bb24ba1639d16c8fa367537bf3b88a6
17 URL:            https://pypi.org/project/casttube/
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.714
20 %if %{with python2}
21 BuildRequires:  python-modules
22 BuildRequires:  python-setuptools
23 %endif
24 %if %{with python3}
25 BuildRequires:  python3-modules
26 BuildRequires:  python3-setuptools
27 %endif
28 Requires:       python-modules
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 casttube provides a way to interact with the Youtube Chromecast api.
34
35 Features:
36 - Play video
37 - Play a playlist
38 - Add video to the end of the play queue
39 - Play next
40 - Remove video
41 - Clear the entire queue
42
43 %package -n python3-%{module}
44 Summary:        casttube provides a way to interact with the Youtube Chromecast api
45 Group:          Libraries/Python
46 Requires:       python3-modules
47
48 %description -n python3-%{module}
49 casttube provides a way to interact with the Youtube Chromecast api.
50
51 Features:
52 - Play video
53 - Play a playlist
54 - Add video to the end of the play queue
55 - Play next
56 - Remove video
57 - Clear the entire queue
58
59 %prep
60 %setup -q -n %{pypi_name}-%{version}
61
62 %build
63 %if %{with python2}
64 %py_build %{?with_tests:test}
65 %endif
66
67 %if %{with python3}
68 %py3_build %{?with_tests:test}
69 %endif
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %if %{with python2}
75 %py_install
76 %endif
77
78 %if %{with python3}
79 %py3_install
80 %endif
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %if %{with python2}
86 %files
87 %defattr(644,root,root,755)
88 %doc README.md
89 %{py_sitescriptdir}/%{module}
90 %{py_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
91 %endif
92
93 %if %{with python3}
94 %files -n python3-%{module}
95 %defattr(644,root,root,755)
96 %doc README.md
97 %{py3_sitescriptdir}/%{module}
98 %{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
99 %endif
This page took 0.071883 seconds and 2 git commands to generate.