]> git.pld-linux.org Git - packages/python-cassandra.git/blob - python-cassandra.spec
c4c40c55e0dbdec3ea522d2bbecfb5715e31f963
[packages/python-cassandra.git] / python-cassandra.spec
1 # TODO:
2 # - Fix tests (seems require mock <= 1.0.1)
3 # - Cleanup cython leftovers
4 #
5 # Conditional build:
6 %bcond_with     doc             # don't build doc
7 %bcond_with     tests   # do not perform "make test"
8 %bcond_without  python2 # CPython 2.x module
9 %bcond_without  python3 # CPython 3.x module
10 # NOTE: 3.7.1 R:  mock<=1.0.1 for tests :/
11
12 %define         module  cassandra
13 Summary:        A Python client driver for Apache Cassandra
14 Summary(pl.UTF-8):      Moduł Pythona dla klientów Apache Cassandra
15 Name:           python-%{module}
16 Version:        3.20.0
17 Release:        4
18 License:        Apache v2.0
19 Group:          Libraries/Python
20 Source0:        https://github.com/datastax/python-driver/archive/%{version}/%{module}-%{version}.tar.gz
21 # Source0-md5:  e812c012c153c3dd1bdb49378cb9ffc5
22 URL:            http://github.com/datastax/python-driver
23 BuildRequires:  libev-devel
24 BuildRequires:  rpm-pythonprov
25 BuildRequires:  rpmbuild(macros) >= 1.710
26 %if %{with python2}
27 ## BuildRequires:       python-futures
28 BuildRequires:  python-PyYAML
29 BuildRequires:  python-devel
30 BuildRequires:  python-distribute
31 BuildRequires:  python-pytz
32 BuildRequires:  python-six
33 BuildRequires:  python-sure
34 Requires:       python-futures
35 Requires:       python-modules
36 #  mock<=1.0.1
37
38 %endif
39 %if %{with python3}
40 # BuildRequires:        python3-futures  # Only 3.0 and 3.1
41 BuildRequires:  python3-PyYAML
42 BuildRequires:  python3-devel
43 BuildRequires:  python3-distribute
44 BuildRequires:  python3-mock
45 BuildRequires:  python3-modules
46 BuildRequires:  python3-pytz
47 BuildRequires:  python3-six >= 1.6
48 BuildRequires:  python3-sure
49 %endif
50 Suggests:       python-blist
51
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %description
55 A Python client driver for Apache Cassandra. This driver works
56 exclusively with the Cassandra Query Language v3 (CQL3) and
57 Cassandra's native protocol. Cassandra versions 1.2 through 2.1 are
58 supported. The driver supports Python 2.6, 2.7, 3.3, and 3.4.
59
60 %description -l pl.UTF-8
61 Interfejs klienta dla Apache Cassandra. Działa wyłacznie w oparciu
62 Cassandra Query Languages v3 (CQL3) i z natywnym protkołem Cassandry.
63 Wspiera Cassndry w wersjach od 1.2 w góre i działa z Pythonem 2.6,
64 2.7, 3.3, 3.4 .
65
66 %package -n python3-%{module}
67 Summary:        A Python client driver for Apache Cassandra
68 Summary(pl.UTF-8):      Moduł Pythona dla klientów Apache Cassandra
69 Group:          Libraries/Python
70 Requires:       python3-six >= 1.6
71 Suggests:       python3-blist
72
73
74 %description -n python3-%{module}
75 A Python client driver for Apache Cassandra. This driver works
76 exclusively with the Cassandra Query Language v3 (CQL3) and
77 Cassandra's native protocol. Cassandra versions 1.2 through 2.1 are
78 supported. The driver supports Python 2.6, 2.7, 3.3, and 3.4.
79
80 %description -n python3-%{module} -l pl.UTF-8
81 Interfejs klienta dla Apache Cassandra. Działa wyłacznie w oparciu
82 Cassandra Query Languages v3 (CQL3) i z natywnym protkołem Cassandry.
83 Wspiera Cassndry w wersjach od 1.2 w góre i działa z Pythonem 2.6,
84 2.7, 3.3, 3.4 .
85
86
87 %package apidocs
88 Summary:        %{module} API documentation
89 Summary(pl.UTF-8):      Dokumentacja API %{module}
90 Group:          Documentation
91
92
93 %description apidocs
94 API documentation for %{module}.
95
96 %description apidocs -l pl.UTF-8
97 Dokumentacja API %{module}.
98
99 %prep
100 %setup -q -n python-driver-%{version}
101
102 %build
103 %if %{with python2}
104 %py_build %{?with_tests:test}
105 %endif
106
107 %if %{with python3}
108 %py3_build %{?with_tests:test}
109 %endif
110
111 %if %{with doc}
112 cd docs
113 %{__make} -j1 html
114 rm -rf _build/html/_sources
115 %endif
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119 %if %{with python2}
120 %py_install
121 %py_postclean
122 %endif
123
124 %if %{with python3}
125 %py3_install
126 %endif
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %if %{with python2}
132 %files
133 %defattr(644,root,root,755)
134 %doc README.rst
135 %dir %{py_sitedir}/%{module}
136 %{py_sitedir}/%{module}/*.py[co]
137 %{py_sitedir}/%{module}/*.pxd
138 %{py_sitedir}/%{module}/*.pyx
139 %attr(755,root,root) %{py_sitedir}/%{module}/*.so
140 %dir %{py_sitedir}/%{module}/cqlengine
141 %{py_sitedir}/%{module}/cqlengine/*.py[co]
142 %dir %{py_sitedir}/%{module}/datastax
143 %{py_sitedir}/%{module}/datastax/*.py[co]
144 %dir %{py_sitedir}/%{module}/datastax/cloud
145 %{py_sitedir}/%{module}/datastax/cloud/*.py[co]
146 %dir %{py_sitedir}/%{module}/io
147 %{py_sitedir}/%{module}/io/*.py[co]
148 %attr(755,root,root) %{py_sitedir}/%{module}/io/libevwrapper.so
149 %{py_sitedir}/cassandra_driver-%{version}-py*.egg-info
150 %endif
151
152 %if %{with python3}
153 %files -n python3-%{module}
154 %defattr(644,root,root,755)
155 %doc README.rst
156 %dir %{py3_sitedir}/%{module}
157 %{py3_sitedir}/%{module}/*.py
158 %{py3_sitedir}/%{module}/*.pxd
159 %{py3_sitedir}/%{module}/*.pyx
160 %attr(755,root,root) %{py3_sitedir}/%{module}/*.cpython-*.so
161 %{py3_sitedir}/%{module}/__pycache__/
162 %dir %{py3_sitedir}/%{module}/io
163 %{py3_sitedir}/%{module}/io/*.py
164 %attr(755,root,root) %{py3_sitedir}/%{module}/io/libevwrapper.cpython-*.so
165 %{py3_sitedir}/%{module}/io/__pycache__
166 %dir %{py3_sitedir}/%{module}/cqlengine
167 %{py3_sitedir}/%{module}/cqlengine/*.py
168 %{py3_sitedir}/%{module}/cqlengine/__pycache__
169 %dir %{py3_sitedir}/%{module}/datastax
170 %{py3_sitedir}/%{module}/datastax/*.py
171 %{py3_sitedir}/%{module}/datastax/__pycache__
172 %dir %{py3_sitedir}/%{module}/datastax/cloud
173 %{py3_sitedir}/%{module}/datastax/cloud/*.py
174 %{py3_sitedir}/%{module}/datastax/cloud/__pycache__
175 %{py3_sitedir}/cassandra_driver-%{version}-py*.egg-info
176 %endif
177
178 %if %{with doc}
179 %files apidocs
180 %defattr(644,root,root,755)
181 %doc docs/_build/html/*
182 %endif
This page took 0.068708 seconds and 2 git commands to generate.