]> git.pld-linux.org Git - packages/python-cassandra.git/blob - python-cassandra.spec
3a09dea02a7c502e04a6d7f98578b9224c098f1e
[packages/python-cassandra.git] / python-cassandra.spec
1 # TODO:
2 # - Fix tests (seems require mock <= 1.0.1)
3 # - Cleanup cython leftovers
4 #
5 # Conditional build:
6 %bcond_with     doc             # don't build doc
7 %bcond_with     tests   # do not perform "make test"
8 %bcond_without  python2 # CPython 2.x module
9 %bcond_without  python3 # CPython 3.x module
10 # NOTE: 3.7.1 R:  mock<=1.0.1 for tests :/
11
12 %define         module  cassandra
13 Summary:        A Python client driver for Apache Cassandra
14 Summary(pl.UTF-8):      Moduł Pythona dla klientów Apache Cassandra
15 Name:           python-%{module}
16 Version:        3.14.0
17 Release:        2
18 License:        Apache v2.0
19 Group:          Libraries/Python
20 Source0:        https://github.com/datastax/python-driver/archive/%{version}.tar.gz
21 # Source0-md5:  d1dfc043ced03165f62ea97c00b9f002
22 URL:            http://github.com/datastax/python-driver
23 BuildRequires:  libev-devel
24 BuildRequires:  rpm-pythonprov
25 BuildRequires:  rpmbuild(macros) >= 1.710
26 %if %{with python2}
27 ## BuildRequires:       python-futures
28 BuildRequires:  python-PyYAML
29 BuildRequires:  python-devel
30 BuildRequires:  python-distribute
31 BuildRequires:  python-pytz
32 BuildRequires:  python-six
33 BuildRequires:  python-sure
34 Requires:       python-futures
35 Requires:       python-modules
36 #  mock<=1.0.1
37
38 %endif
39 %if %{with python3}
40 # BuildRequires:        python3-futures  # Only 3.0 and 3.1
41 BuildRequires:  python3-PyYAML
42 BuildRequires:  python3-devel
43 BuildRequires:  python3-distribute
44 BuildRequires:  python3-mock
45 BuildRequires:  python3-modules
46 BuildRequires:  python3-pytz
47 BuildRequires:  python3-six >= 1.6
48 BuildRequires:  python3-sure
49 %endif
50 Suggests:       python-blist
51
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %description
55 A Python client driver for Apache Cassandra. This driver works
56 exclusively with the Cassandra Query Language v3 (CQL3) and
57 Cassandra's native protocol. Cassandra versions 1.2 through 2.1 are
58 supported. The driver supports Python 2.6, 2.7, 3.3, and 3.4.
59
60 %description -l pl.UTF-8
61 Interfejs klienta dla Apache Cassandra. Działa wyłacznie w oparciu
62 Cassandra Query Languages v3 (CQL3) i z natywnym protkołem Cassandry.
63 Wspiera Cassndry w wersjach od 1.2 w góre i działa z Pythonem 2.6,
64 2.7, 3.3, 3.4 .
65
66 %package -n python3-%{module}
67 Summary:        A Python client driver for Apache Cassandra
68 Summary(pl.UTF-8):      Moduł Pythona dla klientów Apache Cassandra
69 Group:          Libraries/Python
70 Requires:       python3-six >= 1.6
71 Suggests:       python3-blist
72
73
74 %description -n python3-%{module}
75 A Python client driver for Apache Cassandra. This driver works
76 exclusively with the Cassandra Query Language v3 (CQL3) and
77 Cassandra's native protocol. Cassandra versions 1.2 through 2.1 are
78 supported. The driver supports Python 2.6, 2.7, 3.3, and 3.4.
79
80 %description -n python3-%{module} -l pl.UTF-8
81 Interfejs klienta dla Apache Cassandra. Działa wyłacznie w oparciu
82 Cassandra Query Languages v3 (CQL3) i z natywnym protkołem Cassandry.
83 Wspiera Cassndry w wersjach od 1.2 w góre i działa z Pythonem 2.6,
84 2.7, 3.3, 3.4 .
85
86
87 %package apidocs
88 Summary:        %{module} API documentation
89 Summary(pl.UTF-8):      Dokumentacja API %{module}
90 Group:          Documentation
91
92
93 %description apidocs
94 API documentation for %{module}.
95
96 %description apidocs -l pl.UTF-8
97 Dokumentacja API %{module}.
98
99 %prep
100 %setup -q -n python-driver-%{version}
101
102 %build
103 %if %{with python2}
104 %py_build %{?with_tests:test}
105 %endif
106
107 %if %{with python3}
108 %py3_build %{?with_tests:test}
109 %endif
110
111 %if %{with doc}
112 cd docs
113 %{__make} -j1 html
114 rm -rf _build/html/_sources
115 %endif
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119 %if %{with python2}
120 %py_install
121 %py_postclean
122 %endif
123
124 %if %{with python3}
125 %py3_install
126 %endif
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %if %{with python2}
132 %files
133 %defattr(644,root,root,755)
134 %doc README.rst
135 %dir %{py_sitedir}/%{module}
136 %{py_sitedir}/%{module}/*.py[co]
137 %{py_sitedir}/%{module}/*.pxd
138 %{py_sitedir}/%{module}/*.pyx
139 %attr(755,root,root) %{py_sitedir}/%{module}/*.so
140 %dir %{py_sitedir}/%{module}/cqlengine
141 %{py_sitedir}/%{module}/cqlengine/*.py[co]
142 %dir %{py_sitedir}/%{module}/io
143 %{py_sitedir}/%{module}/io/*.py[co]
144 %attr(755,root,root) %{py_sitedir}/%{module}/io/libevwrapper.so
145 %if "%{py_ver}" > "2.4"
146 %{py_sitedir}/cassandra_driver-%{version}-py*.egg-info
147 %endif
148 %endif
149
150 %if %{with python3}
151 %files -n python3-%{module}
152 %defattr(644,root,root,755)
153 %doc README.rst
154 %dir %{py3_sitedir}/%{module}
155 %{py3_sitedir}/%{module}/*.py
156 %{py3_sitedir}/%{module}/*.pxd
157 %{py3_sitedir}/%{module}/*.pyx
158 %attr(755,root,root) %{py3_sitedir}/%{module}/*.cpython-*.so
159 %{py3_sitedir}/%{module}/__pycache__/
160 %dir %{py3_sitedir}/%{module}/io
161 %{py3_sitedir}/%{module}/io/*.py
162 %attr(755,root,root) %{py3_sitedir}/%{module}/io/libevwrapper.cpython-*.so
163 %{py3_sitedir}/%{module}/io/__pycache__
164 %dir %{py3_sitedir}/%{module}/cqlengine
165 %{py3_sitedir}/%{module}/cqlengine/*.py
166 %{py3_sitedir}/%{module}/cqlengine/__pycache__
167 %{py3_sitedir}/cassandra_driver-%{version}-py*.egg-info
168 %endif
169
170 %if %{with doc}
171 %files apidocs
172 %defattr(644,root,root,755)
173 %doc docs/_build/html/*
174 %endif
This page took 0.078998 seconds and 2 git commands to generate.