]> git.pld-linux.org Git - packages/python-cachetools.git/blob - python-cachetools.spec
58177eb40b6362f0937a53a70b6a783cff441614
[packages/python-cachetools.git] / python-cachetools.spec
1 #
2 # Conditional build:
3 %bcond_with     doc             # don't build doc (not provided by package)
4 %bcond_without  tests   # do not perform "make test"
5 %bcond_without  python2 # CPython 2.x module
6 %bcond_without  python3 # CPython 3.x module
7
8 %define         module  cachetools
9 Summary:        Various cache implementations based on different cache algorithms
10 Summary(pl.UTF-8):      Rózne implementacje cache bazujące na róznych algorytmach
11 # Name must match the python module/package name (as in 'import' statement)
12 Name:           python-%{module}
13 Version:        0.7.0
14 Release:        10
15 License:        MIT
16 Group:          Libraries/Python
17
18 Source0:        https://pypi.python.org/packages/source/c/%{module}/%{module}-%{version}.tar.gz
19 # Source0-md5:  c67ebb099e7607b689f79b2869585d36
20 URL:            https://github.com/tkem/cachetools
21 BuildRequires:  rpm-pythonprov
22 # if py_postclean is used
23 BuildRequires:  rpmbuild(macros) >= 1.710
24 %if %{with python2}
25 BuildRequires:  python-distribute
26 %endif
27 %if %{with python3}
28 BuildRequires:  python3-modules
29 %endif
30 Requires:               python-modules
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 This module provides various cache implementations based on different cache algorithms, 
36 as well as decorators for easily memoizing function and method calls.
37
38 %description -l pl.UTF-8
39 Moduł dostarcza rózne implementacje cache'u bazujące na róznych algorytmach, jak również
40 dektoratory do łatwego zapamiętywania wyników funcji i metod.
41
42 %package -n python3-%{module}
43 Summary:        Various cache implementations based on different cache algorithms
44 Summary(pl.UTF-8):      Rózne implementacje cache bazujące na róznych algorytmach
45 Group:          Libraries/Python
46 Requires:               python3-modules
47
48 %description -n python3-%{module}
49 This module provides various cache implementations based on different cache algorithms, 
50 as well as decorators for easily memoizing function and method calls.
51
52 %description -n python3-%{module} -l pl.UTF-8
53 Moduł dostarcza rózne implementacje cache'u bazujące na róznych algorytmach, jak również
54 dektoratory do łatwego zapamiętywania wyników funcji i metod.
55
56 %package apidocs
57 Summary:        %{module} API documentation
58 Summary(pl.UTF-8):      Dokumentacja API %{module}
59 Group:          Documentation
60
61 %description apidocs
62 API documentation for %{module}.
63
64 %description apidocs -l pl.UTF-8
65 Dokumentacja API %{module}.
66
67 %prep
68 %setup -q -n %{module}-%{version}
69
70 %build
71 %if %{with python2}
72 %py_build %{?with_tests:test}
73 %endif
74
75 %if %{with python3}
76 %py3_build %{?with_tests:test}
77 %endif
78
79 %if %{with doc}
80 cd docs
81 %{__make} -j1 html
82 rm -rf _build/html/_sources
83 %endif
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87
88 %if %{with python2}
89 %py_install
90
91 %py_postclean
92 %endif
93
94 %if %{with python3}
95 %py3_install
96 %endif
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %if %{with python2}
102 %files
103 %defattr(644,root,root,755)
104 %doc LICENSE README.rst
105 %{py_sitescriptdir}/%{module}
106 %if "%{py_ver}" > "2.4"
107 %{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
108 %endif
109 %endif
110
111 %if %{with python3}
112 %files -n python3-%{module}
113 %defattr(644,root,root,755)
114 %doc LICENSE README.rst
115 %{py3_sitescriptdir}/%{module}
116 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
117 %endif
118
119 %if %{with doc}
120 %files apidocs
121 %defattr(644,root,root,755)
122 %doc docs/_build/html/*
123 %endif
This page took 0.079446 seconds and 2 git commands to generate.