]> git.pld-linux.org Git - packages/python-burn.git/blob - python-burn.spec
- noarch package
[packages/python-burn.git] / python-burn.spec
1 %define         module  burn
2 Summary:        simple and quick way to burn CDs or DVDs
3 Summary(pl.UTF-8):      prosty skrypt umożliwiający wypalanie CD/DVD
4 Name:           python-%{module}
5 Version:        0.4.4
6 Release:        4
7 License:        GPL v2
8 Group:          Development/Languages/Python
9 Source0:        http://www.bigpaul.org/burn/download/%{module}-%{version}.tar.gz
10 # Source0-md5:  89526cac818f216eb93407b47d05f971
11 Patch0:         %{name}-confdir.patch
12 URL:            http://www.bigpaul.org/burn/
13 BuildRequires:  python-devel
14 BuildRequires:  python-setuptools
15 BuildRequires:  rpm-pythonprov
16 BuildRequires:  rpmbuild(macros) >= 1.710
17 Requires:       cdrdao
18 Requires:       cdrecord
19 Requires:       mkisofs
20 Requires:       python-eyeD3
21 Requires:       python-mad
22 Requires:       python-modules
23 Requires:       python-pyao
24 Requires:       python-pyvorbis
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Burn is a simple program/script written in Python. It's aim is to make
30 it simple and quick to burn CDs or DVDs.
31
32 %description -l pl.UTF-8
33 Burn jest prostym skryptem napisanym w języku Python. Jego zadaniem
34 jest umożliwienie wypalenia płyt CD/DVD w możliwie prosty i szybki
35 sposób.
36
37 %prep
38 %setup -q -n %{module}-%{version}
39 %patch0 -p1
40
41 %build
42 %py_build
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 %py_install
47
48 install -d $RPM_BUILD_ROOT%{_sysconfdir}/burn
49 install -d $RPM_BUILD_ROOT%{_mandir}/man1
50 cp doc/{burn.1,burn-configure.1} $RPM_BUILD_ROOT%{_mandir}/man1
51 cp burn.conf $RPM_BUILD_ROOT%{_sysconfdir}/burn
52
53 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
54 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
55 %py_postclean
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc doc/AUTHORS doc/BUGS changelog doc/KNOWN_BUGS README doc/TODO doc/WISHLIST burn.conf-dist burn.conf
63 %dir %{_sysconfdir}/burn
64 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/burn/burn.conf
65 %attr(755,root,root) %{_bindir}/burn
66 %attr(755,root,root) %{_bindir}/burn-configure
67 %dir %{py_sitescriptdir}/burnlib
68 %{py_sitescriptdir}/burnlib/*.py[co]
69 %if "%{py_ver}" > "2.4"
70 %{py_sitescriptdir}/%{module}-%{version}-*.egg-info
71 %endif
72 %{_mandir}/man1/burn.1*
73 %{_mandir}/man1/burn-configure.1*
This page took 0.065022 seconds and 3 git commands to generate.