]> git.pld-linux.org Git - packages/python-breathe.git/blob - python-breathe.spec
3593999117f209e2ed6b2ee32633e29066ea1a96
[packages/python-breathe.git] / python-breathe.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # do not perform "make test"
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 Summary:        Sphinx Doxygen renderer
8 Summary(pl.UTF-8):      Renderer Doxygena dla systemu dokumentacji Sphinx
9 Name:           python-breathe
10 Version:        1.0.0
11 Release:        3
12 License:        BSD
13 Group:          Development/Languages/Python
14 Source0:        https://github.com/michaeljones/breathe/archive/v%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  a1617f9cb555bbd618257d70e577909f
16 URL:            https://github.com/michaeljones/breathe
17 BuildRequires:  python >= 1:2.5
18 %if %{with python2}
19 BuildRequires:  python-modules
20 %endif
21 %if %{with python3}
22 BuildRequires:  python3-modules
23 %endif
24 BuildRequires:  rpm-pythonprov
25 BuildRequires:  rpmbuild(macros) >= 1.710
26 Requires:       python-Sphinx >= 1.0.7
27 Requires:       python-docutils >= 0.5
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Breathe is an extension to reStructuredText and Sphinx to be able to
33 read and render the Doxygen XML output.
34
35 %description -l pl.UTF-8
36 Breathe to rozszerzenie do systemu dokumentacji reStructuredText i
37 Sphinx, pozwalające na odczyt i renderowanie wyjścia XML z Doxygena.
38
39 %package -n python3-breathe
40 Summary:        Sphinx Doxygen renderer
41 Summary(pl.UTF-8):      Renderer Doxygena dla systemu dokumentacji Sphinx
42 Group:          Libraries/Python
43 Requires:       python3-modules
44 Requires:       python3-Sphinx >= 1.0.7
45 Requires:       python3-docutils >= 0.5
46
47 %description -n python3-breathe
48 Breathe is an extension to reStructuredText and Sphinx to be able to
49 read and render the Doxygen XML output.
50
51 %description -n python3-breathe -l pl.UTF-8
52 Breathe to rozszerzenie do systemu dokumentacji reStructuredText i
53 Sphinx, pozwalające na odczyt i renderowanie wyjścia XML z Doxygena.
54
55 %prep
56 %setup -q -n breathe-%{version}
57
58 %build
59 %if %{with python2}
60 %py_build %{?with_tests:test}
61 %endif
62
63 %if %{with python3}
64 %py3_build %{?with_tests:test}
65 %endif
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69
70 %if %{with python2}
71 %py_install
72
73 %py_postclean
74 %endif
75
76 %if %{with python3}
77 %py3_install
78 %endif
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %files
84 %defattr(644,root,root,755)
85 %doc LICENCE README.rst
86 %{py_sitescriptdir}/breathe
87 %{py_sitescriptdir}/breathe-%{version}-py*.egg-info
88
89 %files -n python3-breathe
90 %defattr(644,root,root,755)
91 %doc LICENCE README.rst
92 %{py3_sitescriptdir}/breathe
93 %{py3_sitescriptdir}/breathe-%{version}-py*.egg-info
This page took 0.086066 seconds and 2 git commands to generate.