]> git.pld-linux.org Git - packages/python-botocore.git/blob - python-botocore.spec
- new
[packages/python-botocore.git] / python-botocore.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Sphinx documentation
4 %bcond_with     tests   # unit tests (die with MemoryError)
5 %bcond_without  python2 # CPython 2.x module
6 %bcond_without  python3 # CPython 3.x module
7
8 Summary:        Low-level, data-driven core of boto 3
9 Summary(pl.UTF-8):      Niskopoziomowy, oparty na danych rdzeń boto 3
10 Name:           python-botocore
11 Version:        1.20.5
12 Release:        1
13 License:        Apache v2.0
14 Group:          Libraries/Python
15 #Source0Download: https://pypi.org/simple/botocore/
16 Source0:        https://files.pythonhosted.org/packages/source/b/botocore/botocore-%{version}.tar.gz
17 # Source0-md5:  22e2131b194cceb09adda93cd7033496
18 URL:            https://pypi.org/project/botocore/
19 %if %{with python2}
20 BuildRequires:  python-modules >= 1:2.7
21 BuildRequires:  python-setuptools
22 %if %{with tests}
23 BuildRequires:  python-behave >= 1.2.5
24 BuildRequires:  python-dateutil >= 2.1
25 BuildRequires:  python-jmespath >= 0.7.1
26 BuildRequires:  python-jsonschema >= 2.5.1
27 BuildRequires:  python-mock >= 1.3.0
28 BuildRequires:  python-nose >= 1.3.7
29 BuildRequires:  python-urllib3 >= 1.25.4
30 %endif
31 %endif
32 %if %{with python3}
33 BuildRequires:  python3-modules >= 1:3.6
34 BuildRequires:  python3-setuptools
35 %if %{with tests}
36 BuildRequires:  python3-behave >= 1.2.5
37 BuildRequires:  python3-dateutil >= 2.1
38 BuildRequires:  python3-jmespath >= 0.7.1
39 BuildRequires:  python3-jsonschema >= 2.5.1
40 BuildRequires:  python3-nose >= 1.3.7
41 BuildRequires:  python3-urllib3 >= 1.25.4
42 %endif
43 %endif
44 BuildRequires:  rpm-pythonprov
45 BuildRequires:  rpmbuild(macros) >= 1.714
46 %if %{with doc}
47 BuildRequires:  python3-guzzle_sphinx_theme
48 BuildRequires:  sphinx-pdg-3
49 %endif
50 Requires:       python-modules >= 1:2.7
51 BuildArch:      noarch
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %description
55 A low-level interface to a growing number of Amazon Web Services. The
56 botocore package is the foundation for the AWS CLI
57 (<https://github.com/aws/aws-cli>) as well as boto3
58 (<https://github.com/boto/boto3>).
59
60 %description -l pl.UTF-8
61 Niskopoziomowy interfejs do rosnącej liczby usług Amazon Web Services.
62 Pakiet botocore jest podstawą dla AWS CLI
63 (<https://github.com/aws/aws-cli>), jak i boto3
64 (<https://github.com/boto/boto3>).
65
66 %package -n python3-botocore
67 Summary:        Low-level, data-driven core of boto 3
68 Summary(pl.UTF-8):      Niskopoziomowy, oparty na danych rdzeń boto 3
69 Group:          Libraries/Python
70 Requires:       python3-modules >= 1:3.6
71
72 %description -n python3-botocore
73 A low-level interface to a growing number of Amazon Web Services. The
74 botocore package is the foundation for the AWS CLI
75 (<https://github.com/aws/aws-cli>) as well as boto3
76 (<https://github.com/boto/boto3>).
77
78 %description -n python3-botocore -l pl.UTF-8
79 Niskopoziomowy interfejs do rosnącej liczby usług Amazon Web Services.
80 Pakiet botocore jest podstawą dla AWS CLI
81 (<https://github.com/aws/aws-cli>), jak i boto3
82 (<https://github.com/boto/boto3>).
83
84 %package apidocs
85 Summary:        API documentation for Python botocore module
86 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona botocore
87 Group:          Documentation
88
89 %description apidocs
90 API documentation for Python botocore module.
91
92 %description apidocs -l pl.UTF-8
93 Dokumentacja API modułu Pythona botocore.
94
95 %prep
96 %setup -q -n botocore-%{version}
97
98 %build
99 %if %{with python2}
100 %py_build
101
102 %if %{with tests}
103 PYTHONPATH=$(pwd) \
104 nosetests-%{py_ver} tests
105 %endif
106 %endif
107
108 %if %{with python3}
109 %py3_build
110
111 %if %{with tests}
112 PYTHONPATH=$(pwd) \
113 nosetests-%{py3_ver} tests
114 %endif
115 %endif
116
117 %if %{with doc}
118 PYTHONPATH=$(pwd) \
119 %{__make} -C docs html \
120         SPHINXBUILD=sphinx-build-3
121 %endif
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125
126 %if %{with python2}
127 %py_install
128
129 %py_postclean
130 %endif
131
132 %if %{with python3}
133 %py3_install
134 %endif
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %if %{with python2}
140 %files
141 %defattr(644,root,root,755)
142 %doc README.rst
143 %{py_sitescriptdir}/botocore
144 %{py_sitescriptdir}/botocore-%{version}-py*.egg-info
145 %endif
146
147 %if %{with python3}
148 %files -n python3-botocore
149 %defattr(644,root,root,755)
150 %doc README.rst
151 %{py3_sitescriptdir}/botocore
152 %{py3_sitescriptdir}/botocore-%{version}-py*.egg-info
153 %endif
154
155 %if %{with doc}
156 %files apidocs
157 %defattr(644,root,root,755)
158 %doc docs/build/html/{_static,development,reference,topics,tutorial,*.html,*.js}
159 %endif
This page took 0.343839 seconds and 3 git commands to generate.