]> git.pld-linux.org Git - packages/python-boto3.git/blob - python-boto3.spec
e7ff87c68aab16a4979a49993d856f8dc6741712
[packages/python-boto3.git] / python-boto3.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # unit tests (not included in sdist)
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 Summary:        AWS SDK for Python 2
8 Summary(pl.UTF-8):      AWS SDK dla Pythona 2
9 Name:           python-boto3
10 # keep 1.17.x here for python2 support
11 Version:        1.17.112
12 Release:        1
13 License:        Apache v2.0
14 Group:          Libraries/Python
15 #Source0Download: https://pypi.org/simple/boto3/
16 Source0:        https://files.pythonhosted.org/packages/source/b/boto3/boto3-%{version}.tar.gz
17 # Source0-md5:  fc5e9145eb1fbc0601c94ed3918f1508
18 URL:            https://pypi.org/project/boto3/
19 %if %{with python2}
20 BuildRequires:  python-modules >= 1:2.7
21 BuildRequires:  python-setuptools
22 %if %{with tests}
23 BuildRequires:  python-botocore >= 1.20.112
24 BuildRequires:  python-botocore < 1.21
25 BuildRequires:  python-jmespath >= 0.7.1
26 BuildRequires:  python-jmespath < 1
27 BuildRequires:  python-mock >= 1.3.0
28 BuildRequires:  python-nose >= 1.3.3
29 BuildRequires:  python-s3transfer >= 0.4.0
30 BuildRequires:  python-s3transfer < 0.5
31 %endif
32 %endif
33 %if %{with python3}
34 BuildRequires:  python3-modules >= 1:3.6
35 BuildRequires:  python3-setuptools
36 %if %{with tests}
37 BuildRequires:  python3-botocore >= 1.20.112
38 BuildRequires:  python3-botocore < 1.21
39 BuildRequires:  python3-jmespath >= 0.7.1
40 BuildRequires:  python3-jmespath < 1
41 BuildRequires:  python3-nose >= 1.3.3
42 BuildRequires:  python3-s3transfer >= 0.4.0
43 BuildRequires:  python3-s3transfer < 0.5
44 %endif
45 %endif
46 BuildRequires:  rpm-pythonprov
47 BuildRequires:  rpmbuild(macros) >= 1.714
48 Requires:       python-modules >= 1:2.7
49 BuildArch:      noarch
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %description
53 Boto3 is the Amazon Web Services (AWS) Software Development Kit (SDK)
54 for Python, which allows Python developers to write software that
55 makes use of services like Amazon S3 and Amazon EC2.
56
57 %description -l pl.UTF-8
58 Boto3 to pakiet programistyczny (SDK) usług AWS (Amazon Web Services),
59 pozwalający na pisanie w Pythonie oprogramowania wykorzystującego
60 usługi takie jak Amazon S3 i Amazon EC2.
61
62 %package -n python3-boto3
63 Summary:        AWS SDK for Python 3
64 Summary(pl.UTF-8):      AWS SDK dla Pythona 3
65 Group:          Libraries/Python
66 Requires:       python3-modules >= 1:3.6
67
68 %description -n python3-boto3
69 Boto3 is the Amazon Web Services (AWS) Software Development Kit (SDK)
70 for Python, which allows Python developers to write software that
71 makes use of services like Amazon S3 and Amazon EC2.
72
73 %description -n python3-boto3 -l pl.UTF-8
74 Boto3 to pakiet programistyczny (SDK) usług AWS (Amazon Web Services),
75 pozwalający na pisanie w Pythonie oprogramowania wykorzystującego
76 usługi takie jak Amazon S3 i Amazon EC2.
77
78 %prep
79 %setup -q -n boto3-%{version}
80
81 %build
82 %if %{with python2}
83 %py_build
84
85 %if %{with tests}
86 nosetests-%{py_ver} tests
87 %endif
88 %endif
89
90 %if %{with python3}
91 %py3_build
92
93 %if %{with tests}
94 nosetests-%{py3_ver} tests
95 %endif
96 %endif
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100
101 %if %{with python2}
102 %py_install
103
104 %py_postclean
105 %endif
106
107 %if %{with python3}
108 %py3_install
109 %endif
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %if %{with python2}
115 %files
116 %defattr(644,root,root,755)
117 %doc README.rst
118 %{py_sitescriptdir}/boto3
119 %{py_sitescriptdir}/boto3-%{version}-py*.egg-info
120 %endif
121
122 %if %{with python3}
123 %files -n python3-boto3
124 %defattr(644,root,root,755)
125 %doc README.rst
126 %{py3_sitescriptdir}/boto3
127 %{py3_sitescriptdir}/boto3-%{version}-py*.egg-info
128 %endif
This page took 0.053031 seconds and 2 git commands to generate.