]> git.pld-linux.org Git - packages/python-boto.git/blob - python-boto.spec
1c379db64652d0443c5ead4b4b0dafa93418fcfa
[packages/python-boto.git] / python-boto.spec
1 %bcond_without  python2 # CPython 2.x module
2 %bcond_without  python3 # CPython 3.x module
3
4 %define module boto
5 Summary:        An integrated interface to infrastructural services offered by Amazon Web Services
6 Summary(pl.UTF-8):      Zintegrowany interfejs do usług infrastruktury oferowanych przez usługi WWW Amazon
7 Name:           python-%{module}
8 Version:        2.42.0
9 Release:        4
10 License:        MIT
11 Group:          Libraries/Python
12 Source0:        https://pypi.python.org/packages/c4/bb/28324652bedb4ea9ca77253b84567d1347b54df6231b51822eaaa296e6e0/boto-%{version}.tar.gz
13 # Source0-md5:  62b6ef1af3d18f8811f97e311b856dad
14 URL:            https://github.com/boto/boto
15 BuildRequires:  python-devel
16 BuildRequires:  rpm-pythonprov
17 BuildRequires:  rpmbuild(macros) >= 1.710
18 Requires:       python-libs
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 An integrated interface to current and future infrastructural services
24 offered by Amazon Web Services.
25
26 %description -l pl.UTF-8
27 Zintegrowany interfejs do aktualnych i przyszłych usług infrastruktury
28 oferowanych przez usługi WWW Amazon.
29
30 %package -n python3-%{module}
31 Summary:        An integrated interface to infrastructural services offered by Amazon Web Services
32 Summary(pl.UTF-8):      Zintegrowany interfejs do usług infrastruktury oferowanych przez usługi WWW Amazon
33 Group:          Libraries/Python
34
35 %description -n python3-%{module}
36 An integrated interface to current and future infrastructural services
37 offered by Amazon Web Services.
38
39 %description -n python3-%{module} -l pl.UTF-8
40 Zintegrowany interfejs do aktualnych i przyszłych usług infrastruktury
41 oferowanych przez usługi WWW Amazon.
42
43 %package -n boto
44 Summary:        Python utilities for Amazon Web Services
45 Group:          Applications
46 Requires:       %{name} = %{version}-%{release}
47
48 %description -n boto
49 Boto is an integrated Python interface to current and future
50 infrastructural services offered by Amazon Web Services.
51
52 This package includes sample utilities implemented with this API.
53
54 %prep
55 %setup -q -n %{module}-%{version}
56
57 %build
58 %if %{with python3}
59 %py3_build %{?with_tests:test}
60 %endif
61
62 %if %{with python2}
63 %py_build %{?with_tests:test}
64 %endif
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %if %{with python3}
70 %py3_install
71 rm -rf $RPM_BUILD_ROOT%{py3_sitescriptdir}/tests
72 %endif
73
74 %if %{with python2}
75 rm -rf $RPM_BUILD_ROOT%{_bindir}
76 %py_install
77
78 rm -rf $RPM_BUILD_ROOT%{py_sitescriptdir}/tests
79 %py_postclean
80 %endif
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(644,root,root,755)
87 %doc PKG-INFO README*
88 %{py_sitescriptdir}/boto
89 %{py_sitescriptdir}/boto-*.egg-info
90
91 %files -n python3-%{module}
92 %defattr(644,root,root,755)
93 %doc PKG-INFO README*
94 %{py3_sitescriptdir}/boto
95 %{py3_sitescriptdir}/boto-*.egg-info
96
97 %files -n boto
98 %defattr(644,root,root,755)
99 %attr(755,root,root) %{_bindir}/*
This page took 0.061182 seconds and 2 git commands to generate.