]> git.pld-linux.org Git - packages/python-boltons.git/blob - python-boltons.spec
d99a2df4f8076a540d72e6373b2c4d75f1e25088
[packages/python-boltons.git] / python-boltons.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 Summary:        When they're not builtins, they're boltons
8 Summary(pl.UTF-8):      To, co nie jest wbudowane, jest w boltons
9 Name:           python-boltons
10 Version:        21.0.0
11 Release:        1
12 License:        BSD
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.org/simple/boltons/
15 Source0:        https://files.pythonhosted.org/packages/source/b/boltons/boltons-%{version}.tar.gz
16 # Source0-md5:  c7a17577f80a5c3316b8cb61b79d09c9
17 URL:            https://pypi.org/project/boltons/
18 %if %{with python2}
19 BuildRequires:  python-modules >= 1:2.7
20 BuildRequires:  python-setuptools
21 %if %{with tests}
22 BuildRequires:  python-pytest
23 %endif
24 %endif
25 %if %{with python3}
26 BuildRequires:  python3-modules >= 1:3.4
27 BuildRequires:  python3-setuptools
28 %if %{with tests}
29 BuildRequires:  python3-pytest
30 %endif
31 %endif
32 BuildRequires:  rpm-pythonprov
33 BuildRequires:  rpmbuild(macros) >= 1.714
34 Requires:       python-modules >= 1:2.7
35 BuildArch:      noarch
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Functionality that should be in the standard library. Like builtins,
40 but Boltons.
41
42 %description -l pl.UTF-8
43 Funkcjonalność, która powinna być w bibliotece standardowej, Podobnie
44 jak builtins, ale to są Boltons.
45
46 %package -n python3-boltons
47 Summary:        When they're not builtins, they're boltons
48 Summary(pl.UTF-8):      To, co nie jest wbudowane, jest w boltons
49 Group:          Libraries/Python
50 Requires:       python3-modules >= 1:3.4
51
52 %description -n python3-boltons
53 Functionality that should be in the standard library. Like builtins,
54 but Boltons.
55
56 %description -n python3-boltons -l pl.UTF-8
57 Funkcjonalność, która powinna być w bibliotece standardowej, Podobnie
58 jak builtins, ale to są Boltons.
59
60 %prep
61 %setup -q -n boltons-%{version}
62
63 %build
64 %if %{with python2}
65 %py_build
66
67 %if %{with tests}
68 PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
69 %{__python} -m pytest --doctest-modules boltons
70 %endif
71 %endif
72
73 %if %{with python3}
74 %py3_build
75
76 %if %{with tests}
77 PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
78 %{__python3} -m pytest --doctest-modules boltons
79 %endif
80 %endif
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84
85 %if %{with python2}
86 %py_install
87
88 %py_postclean
89 %endif
90
91 %if %{with python3}
92 %py3_install
93 %endif
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %if %{with python2}
99 %files
100 %defattr(644,root,root,755)
101 %doc CHANGELOG.md LICENSE README.md TODO.rst
102 %{py_sitescriptdir}/boltons
103 %{py_sitescriptdir}/boltons-%{version}-py*.egg-info
104 %endif
105
106 %if %{with python3}
107 %files -n python3-boltons
108 %defattr(644,root,root,755)
109 %doc CHANGELOG.md LICENSE README.md TODO.rst
110 %{py3_sitescriptdir}/boltons
111 %{py3_sitescriptdir}/boltons-%{version}-py*.egg-info
112 %endif
This page took 0.092276 seconds and 2 git commands to generate.