]> git.pld-linux.org Git - packages/python-blivet.git/blob - python-blivet.spec
c00e94895fc69e6bd13542668635b3f9c0c2137d
[packages/python-blivet.git] / python-blivet.spec
1 %define module blivet
2 Summary:        A Python module for system storage configuration
3 Name:           python-blivet
4 Version:        0.14
5 Release:        2
6 License:        GPL v2+
7 Group:          Libraries/Python
8 Source0:        http://pkgs.fedoraproject.org/repo/pkgs/python-blivet/%{module}-%{version}.tar.gz/30592cc8261fb936023b9d466dec68da/%{module}-%{version}.tar.gz
9 # Source0-md5:  30592cc8261fb936023b9d466dec68da
10 Patch0:         lvm-lvmetad.patch
11 URL:            http://fedoraproject.org/wiki/blivet
12 BuildRequires:  gettext-tools
13 BuildRequires:  python-distribute
14 BuildRequires:  rpm-pythonprov
15 BuildRequires:  rpmbuild(macros) >= 1.710
16 Requires:       btrfs-progs
17 Requires:       cryptsetup-luks
18 Requires:       device-mapper >= 1.02.17-6
19 Requires:       dosfstools
20 Requires:       e2fsprogs >= 1.41.0
21 Requires:       lvm2 >= 2.02.98-3
22 Requires:       mdadm
23 Requires:       multipath-tools >= 0.4.9-10
24 Requires:       parted >= 1.8.1
25 Requires:       python
26 Requires:       python-cryptsetup >= 0.1.1
27 Requires:       python-parted >= 2.5-2
28 Requires:       python-pyblock >= 0.45
29 Requires:       python-pykickstart >= 1.99.22
30 Requires:       util-linux >= 2.22.2-6
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 The python-blivet package is a Python module for examining and
36 modifying storage configuration.
37
38 %prep
39 %setup -q -n %{module}-%{version}
40 %patch0 -p1
41
42 %build
43 %{__make}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
51 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
52
53 # redo python install to get optimize=2
54 %py_install
55
56 %py_postclean
57
58 # unsupported locale
59 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ilo
60
61 %find_lang %{module}
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files -f %{module}.lang
67 %defattr(644,root,root,755)
68 %doc README ChangeLog
69 %{py_sitescriptdir}/blivet
70 %{py_sitescriptdir}/blivet-%{version}-py*.egg-info
71 %{_examplesdir}/%{name}-%{version}
This page took 0.047283 seconds and 2 git commands to generate.