]> git.pld-linux.org Git - packages/python-blist.git/blob - python-blist.spec
aa7cc1a3a4b6e047fe06d53d2447cd9d47079370
[packages/python-blist.git] / python-blist.spec
1 #
2 # Conditional build:
3 %bcond_with     doc             # don't build doc
4 %bcond_without  tests   # do not perform "make test"
5 %bcond_without  python2 # CPython 2.x module
6 %bcond_without  python3 # CPython 3.x module
7
8 %define         module  blist
9 Summary:        The blist is a drop-in replacement for the Python list that provides better performance when modifying large lists
10 Summary(pl.UTF-8):      Blist jest zamiennikiem dla Pythonowych list który jest szybszy przy modifikacjach dużych list
11 Name:           python-%{module}
12 Version:        1.3.6
13 Release:        9
14 License:        BSD
15 Group:          Libraries/Python
16 Source0:        http://pypi.python.org/packages/source/b/%{module}/%{module}-%{version}.tar.gz
17 # Source0-md5:  a538f1a24b9191e3c40252e9397408a9
18 URL:            http://stutzbachenterprises.com/blist/
19 BuildRequires:  rpm-pythonprov
20 # if py_postclean is used
21 BuildRequires:  rpmbuild(macros) >= 1.710
22 %if %{with python2}
23 BuildRequires:  python-devel
24 BuildRequires:  python-distribute
25 %endif
26 %if %{with python3}
27 BuildRequires:  python3-devel
28 BuildRequires:  python3-distribute
29 BuildRequires:  python3-modules
30 %endif
31 Requires:               python-modules
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 The blist is a drop-in replacement for the Python list that provides better performance when modifying large lists. 
36 The blist package also provides sortedlist, sortedset, weaksortedlist, weaksortedset, sorteddict, and btuple types
37
38 %description -l pl.UTF-8
39 Blist jest zamiennikiem dla Pythonowych list który jest szybszy przy modifikacjach dużych list.
40 Pakiet blist udostępnia też typy: sortedlist, sortedset, weaksortedlist, weaksortedset, sorteddict, and btuple.
41
42 %package -n python3-%{module}
43 Summary:        -
44 Summary(pl.UTF-8):      -
45 Group:          Libraries/Python
46 Requires:               python3-modules
47
48 %description -n python3-%{module}
49 The blist is a drop-in replacement for the Python list that provides better performance when modifying large lists
50
51 %description -n python3-%{module} -l pl.UTF-8
52 Blist jest zamiennikiem dla Pythonowych list który jest szybszy przy modifikacjach dużych list.
53 Pakiet blist udostępnia też typy: sortedlist, sortedset, weaksortedlist, weaksortedset, sorteddict, and btuple.
54
55 %package apidocs
56 Summary:        %{module} API documentation
57 Summary(pl.UTF-8):      Dokumentacja API %{module}
58 Group:          Documentation
59
60 %description apidocs
61 API documentation for %{module}.
62
63 %description apidocs -l pl.UTF-8
64 Dokumentacja API %{module}.
65
66 %prep
67 %setup -q -n %{module}-%{version}
68
69 %build
70 %if %{with python2}
71 %py_build %{?with_tests:test}
72 %endif
73
74 %if %{with python3}
75 %py3_build %{?with_tests:test}
76 %endif
77
78 %if %{with doc}
79 cd docs
80 %{__make} -j1 html
81 rm -rf _build/html/_sources
82 %endif
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86
87 %if %{with python2}
88 %py_install
89
90 %py_postclean
91 %endif
92
93 %if %{with python3}
94 %py3_install
95 %endif
96
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %if %{with python2}
102 %files
103 %defattr(644,root,root,755)
104 %doc README.rst
105 %dir %{py_sitedir}/%{module}
106 %{py_sitedir}/%{module}/*.py[co]
107 %attr(755,root,root) %{py_sitedir}/%{module}/_blist.so
108 %if "%{py_ver}" > "2.4"
109 %{py_sitedir}/%{module}-%{version}-py*.egg-info
110 %endif
111 %endif
112
113 %if %{with python3}
114 %files -n python3-%{module}
115 %defattr(644,root,root,755)
116 %doc README.rst
117 %dir %{py3_sitedir}/%{module}
118 %{py3_sitedir}/%{module}/*.py
119 %{py3_sitedir}/%{module}/__pycache__
120 %attr(755,root,root) %{py3_sitedir}/%{module}/_blist.cpython-*.so
121 %{py3_sitedir}/%{module}-%{version}-py*.egg-info
122 %endif
123
124 %if %{with doc}
125 %files apidocs
126 %defattr(644,root,root,755)
127 %doc docs/_build/html/*
128 %endif
This page took 0.136707 seconds and 2 git commands to generate.