]> git.pld-linux.org Git - packages/python-blinker.git/blob - python-blinker.spec
1d4700494d8ca90e7295443cd36e5b989370464f
[packages/python-blinker.git] / python-blinker.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # API documentation
4 %bcond_without  tests   # unit tests
5 %bcond_without  python2 # CPython 2.x module
6 %bcond_without  python3 # CPython 3.x module
7
8 %define         module  blinker
9 Summary:        Fast, simple object-to-object and broadcast signaling
10 Summary(pl.UTF-8):      Szybkie, proste przesyłanie sygnałów pomiędzy obiektami
11 Name:           python-%{module}
12 Version:        1.4
13 Release:        5
14 License:        MIT
15 Group:          Libraries/Python
16 #Source0Download: https://pypi.org/simple/blinker/
17 Source0:        https://files.pythonhosted.org/packages/source/b/blinker/%{module}-%{version}.tar.gz
18 # Source0-md5:  8b3722381f83c2813c52de3016b68d33
19 URL:            https://pythonhosted.org/blinker/
20 BuildRequires:  rpm-pythonprov
21 BuildRequires:  rpmbuild(macros) >= 1.714
22 %if %{with python2}
23 BuildRequires:  python-modules >= 1:2.5
24 BuildRequires:  python-setuptools
25 %if %{with tests}
26 BuildRequires:  python-nose
27 %endif
28 %endif
29 %if %{with python3}
30 BuildRequires:  python3-modules >= 1:3.2
31 BuildRequires:  python3-setuptools
32 %if %{with tests}
33 BuildRequires:  python3-nose
34 %endif
35 %endif
36 %if %{with doc}
37 BuildRequires:  python3-flask_sphinx_themes
38 BuildRequires:  sphinx-pdg-3
39 %endif
40 Requires:       python-modules >= 1:2.5
41 BuildArch:      noarch
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 Blinker provides a fast dispatching system that allows any number of
46 interested parties to subscribe to events, or "signals". Signal
47 receivers can subscribe to specific senders or receive signals sent by
48 any sender.
49
50 %description -l pl.UTF-8
51 Blinker dostarcza szybki system rozporowadzania sygnałów, który
52 pozwala na dowolną liczbę odbiorców zdarzeń czy sygnałów. Odbiorcy
53 sygnałów mogą zapisywać się do wybranych nadawców lub odbierać sygnały
54 nadadane przez wszystkich nadawców.
55
56 %package -n python3-%{module}
57 Summary:        Fast, simple object-to-object and broadcast signaling
58 Summary(pl.UTF-8):      Szybkie, proste przesyłanie sygnałów pomiędzy obiektami
59 Group:          Libraries/Python
60 Requires:       python3-modules >= 1:3.2
61
62 %description -n python3-%{module}
63 Blinker provides a fast dispatching system that allows any number of
64 interested parties to subscribe to events, or "signals". Signal
65 receivers can subscribe to specific senders or receive signals sent by
66 any sender.
67
68 %description -n python3-%{module} -l pl.UTF-8
69 Blinker dostarcza szybki system rozporowadzania sygnałów, który
70 pozwala na dowolną liczbę odbiorców zdarzeń czy sygnałów. Odbiorcy
71 sygnałów mogą zapisywać się do wybranych nadawców lub odbierać sygnały
72 nadadane przez wszystkich nadawców.
73
74 %package apidocs
75 Summary:        Blinker API documentation
76 Summary(pl.UTF-8):      Dokumentacja API modułu Blinker
77 Group:          Documentation
78
79 %description apidocs
80 API documentation for Blinker.
81
82 %description apidocs -l pl.UTF-8
83 Dokumentacja API modułu Blinker.
84
85 %prep
86 %setup -q -n %{module}-%{version}
87
88 %build
89 %if %{with python2}
90 %py_build
91
92 %if %{with tests}
93 nosetests-%{py_ver} tests
94 %endif
95 %endif
96
97 %if %{with python3}
98 %py3_build
99
100 %if %{with tests}
101 nosetests-%{py3_ver} tests
102 %endif
103 %endif
104
105 %if %{with doc}
106 sphinx-build-3 -b html docs/source docs/html
107 %endif
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111
112 %if %{with python2}
113 %py_install
114
115 %py_postclean
116 %endif
117
118 %if %{with python3}
119 %py3_install
120 %endif
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %if %{with python2}
126 %files
127 %defattr(644,root,root,755)
128 %doc AUTHORS CHANGES README.md LICENSE
129 %{py_sitescriptdir}/%{module}
130 %{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
131 %endif
132
133 %if %{with python3}
134 %files -n python3-%{module}
135 %defattr(644,root,root,755)
136 %doc AUTHORS CHANGES README.md LICENSE
137 %{py3_sitescriptdir}/%{module}
138 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
139 %endif
140
141 %if %{with doc}
142 %files apidocs
143 %defattr(644,root,root,755)
144 %doc docs/html/{_static,*.html,*.js}
145 %endif
This page took 0.044979 seconds and 2 git commands to generate.