]> git.pld-linux.org Git - packages/python-beniget.git/blob - python-beniget.spec
- new
[packages/python-beniget.git] / python-beniget.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 Summary:        Extract semantic information about static Python code
8 Summary(pl.UTF-8):      Wydobywanie informacji semantycznych o statycznym kodzie w Pythonie
9 Name:           python-beniget
10 Version:        0.4.1
11 Release:        1
12 License:        BSD
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.org/simple/beniget/
15 Source0:        https://files.pythonhosted.org/packages/source/b/beniget/beniget-%{version}.tar.gz
16 # Source0-md5:  a2bbe7f17f10f9c127d8ef00692ddc55
17 URL:            https://pypi.org/project/beniget/
18 %if %{with python2}
19 BuildRequires:  python-modules >= 1:2.7
20 BuildRequires:  python-setuptools
21 %if %{with tests}
22 BuildRequires:  python-gast >= 0.5.0
23 %endif
24 %endif
25 %if %{with python3}
26 BuildRequires:  python3-modules >= 1:3.4
27 BuildRequires:  python3-setuptools
28 %if %{with tests}
29 BuildRequires:  python3-gast >= 0.5.0
30 %endif
31 %endif
32 BuildRequires:  rpm-pythonprov
33 BuildRequires:  rpmbuild(macros) >= 1.714
34 Requires:       python-modules >= 1:2.7
35 BuildArch:      noarch
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 A static analyzer for Python2 and Python3 code.
40
41 Beniget provides a static over-approximation of the global and local
42 definitions inside Python Module/Class/Function. It can also compute
43 def-use chains from each definition.
44
45 %description -l pl.UTF-8
46 Statyczny analizator kodu Pythona 2 i 3.
47
48 Beniget zapewnia statyczną (nad)aproksymację globalnych i lokalnych
49 definicji wewnątrz modułów/klas/funkcji pythonowych. Potrafi także
50 wyliczać łańcuchy def-użyć z każdej definicji.
51
52 %package -n python3-beniget
53 Summary:        Extract semantic information about static Python code
54 Summary(pl.UTF-8):      Wydobywanie informacji semantycznych o statycznym kodzie w Pythonie
55 Group:          Libraries/Python
56 Requires:       python3-modules >= 1:3.4
57
58 %description -n python3-beniget
59 A static analyzer for Python2 and Python3 code.
60
61 Beniget provides a static over-approximation of the global and local
62 definitions inside Python Module/Class/Function. It can also compute
63 def-use chains from each definition.
64
65 %description -n python3-beniget -l pl.UTF-8
66 Statyczny analizator kodu Pythona 2 i 3.
67
68 Beniget zapewnia statyczną (nad)aproksymację globalnych i lokalnych
69 definicji wewnątrz modułów/klas/funkcji pythonowych. Potrafi także
70 wyliczać łańcuchy def-użyć z każdej definicji.
71
72 %prep
73 %setup -q -n beniget-%{version}
74
75 %build
76 %if %{with python2}
77 %py_build %{?with_tests:test}
78 %endif
79
80 %if %{with python3}
81 %py3_build %{?with_tests:test}
82 %endif
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86
87 %if %{with python2}
88 %py_install
89
90 %py_postclean
91 %endif
92
93 %if %{with python3}
94 %py3_install
95 %endif
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %if %{with python2}
101 %files
102 %defattr(644,root,root,755)
103 %doc LICENSE README.rst
104 %{py_sitescriptdir}/beniget
105 %{py_sitescriptdir}/beniget-%{version}-py*.egg-info
106 %endif
107
108 %if %{with python3}
109 %files -n python3-beniget
110 %defattr(644,root,root,755)
111 %doc LICENSE README.rst
112 %{py3_sitescriptdir}/beniget
113 %{py3_sitescriptdir}/beniget-%{version}-py*.egg-info
114 %endif
This page took 0.078645 seconds and 3 git commands to generate.