]> git.pld-linux.org Git - packages/python-bbfreeze.git/blob - python-bbfreeze.spec
automatic change: use py_build/py_install macros
[packages/python-bbfreeze.git] / python-bbfreeze.spec
1 # %bcond_without        tests   # do not perform "make test"
2
3 %define         module  bbfreeze
4 Summary:        Creates stand-alone executables from python scripts
5 Name:           python-%{module}
6 Version:        1.0.2
7 Release:        1
8 License:        zlib/libpng
9 Group:          Development/Languages/Python
10 Source0:        http://pypi.python.org/packages/source/b/bbfreeze/bbfreeze-%{version}.zip
11 # Source0-md5:  53e74d5ae352541732ef2987ad1f68a6
12 URL:            http://pypi.python.org/pypi/bbfreeze
13 BuildRequires:  python-devel
14 BuildRequires:  rpm-pythonprov
15 # if py_postclean is used
16 BuildRequires:  rpmbuild(macros) >= 1.219
17 BuildRequires:  unzip
18 Requires:       python-modules
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 bbfreeze creates stand-alone executables from python scripts. It's
23 similar in purpose to the well known py2exe for windows, py2app for OS
24 X, PyInstaller and cx_Freeze (in fact ancient versions were based on
25 cx_Freeze. And it uses the modulegraph package, which is also used by
26 py2app).
27
28 %prep
29 %setup -q -n bbfreeze-%{version}
30
31 %build
32 %py_build
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36
37 %py_install
38
39 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
40 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
41 %py_postclean
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %files
47 %defattr(644,root,root,755)
48 %attr(755,root,root) %{_bindir}/bb-freeze
49
50 %dir %{py_sitedir}/%{module}
51 %{py_sitedir}/%{module}/*.py[co]
52 %attr(755,root,root) %{py_sitedir}/%{module}/console.exe
53 %dir %{py_sitedir}/%{module}/modulegraph
54 %{py_sitedir}/%{module}/modulegraph/*.py[co]
55 %if "%{py_ver}" > "2.4"
56 %{py_sitedir}/%{module}*.egg-info
57 %endif
This page took 0.047858 seconds and 3 git commands to generate.